Qwaq products enable a rich ecosystem of interlinked 2D and 3D spaces that is as easy to navigate and extend as today’s web. Qwaq products are built on and extend the Croquet open source software platform, and feature a network architecture that supports communication, collaboration, resource sharing, and synchronous computation among multiple users.

Qwaq Forums, our flagship product, provides secure, virtual workspaces for the enterprise. Qwaq Forums can help you to . . .

- optimize the effectiveness of employees as they become more geographically distributed and work on multiple teams simultaneously
- create efficient collaboration with supply chain partners
- broaden and enrich your customers’ experience with you and with other customers

This guide provides a brief introduction to Qwaq technology and supporting tools, explains how to download, install, and start up the Qwaq Forums browser, join a Sample Forum or create a new one, and build out and customize your space in collaboration with others on your team.

About this Help

You can access this guide as a Help document in a Web browser by choosing Help > User Guide from the Qwaq Forums menu. Several “quick reference” Help topics are also provided in the Help menu. This Help is also provided as an in-forum document via the Places > Help Browser forum menu.

For full information on how to use the Help (including Search, Index, Favorites, and navigation features) please see the topic Online Help.

Copyright © 2006-2008 Qwaq, Inc. All Rights Reserved.
Qwaq Forums, Qwaq Virtual Campus and Qwaq Multi-Share are trademarks of Qwaq, Inc.
Keyboard Navigation

Go Back/Next to Previously Visited Forums

Finding and Navigating to Other Users

Gestures for Simple Communication

Setting Present or Away Status

Communicating with Voice and Text Chat

Text Chat

Private Text Chat

Audio Conferencing and Sound

External Component and Software Sound Check

In-Forum Microphone and Speakers

In-Forum Sound Check

Sound/Audio Status of Other Users

Troubleshooting Common Sound Problems

Understanding Presence

Importing Your Content

Supported File Types

Portals and Spaces

2D and 3D Portals

Examples

3D Projections

Linking Forums

Deleting Links to Portals

File Cards

Try this Sample with Portal Cards

Manipulating Objects

Manipulating 3D Objects

Move a 3D Object Any Distance

Rotate an Object

Rotate a 3D Projection

Grab and Carry an Object

Manipulating 2D Objects in Panels
Overview
Welcome to the Qwaq Forums! This User Guide provides an introduction to building collaborative, 3D spaces with the Qwaq Collaboration Platform. We'll give you a brief introduction to Qwaq technology and supporting tools, explain how to download, install, and start the Qwaq Forums Browser, join a Sample Forum or create a new one, and build out and customize a forum in collaboration with others.

The Sample Forum is a template for a space that you can duplicate and customize within a forum. Starting with a Sample Forum or any of the other template forums, you can use the tools to build out the space with provided objects, create new objects, and upload your own content such as pictures, video, sound media, and artifacts from other applications (for example, movies, pictures, spreadsheets, documents, slides, or 3D models).

We also introduce an outdoor space called Campus Forum as an example of how to build structures and link Sample Forums together via portals on a landscape. We'll show you how to:

- Navigate Forum 3D spaces
- Explore and work with objects like portals, panels, postcards, and projections
- Add copies of pre-defined objects into the spaces, modify objects, and remove objects
- Upload your own content to Forums (pictures, media, documents, spreadsheets, models, and other artifacts from various applications).
- Use Forum tools to create 3D models, pictures, media, and artifacts within the space.
- Add new Forums to the space and build out the application to create a matrix of 3D spaces linked together by 3D portals.

What are Qwaq Forums?
Qwaq Forums are secure virtual workspaces designed for distributed collaboration to address the challenges of the modern workplace.

Work is becoming more “virtual”, with people geographically distributed and skill sets dispersed. Many employees belong to several teams at the same time without having a “single center”.

The enterprise requires access to multiple applications and knowledge assets such as:

- Productivity tools and Web browsers
• Corporate applications such as ERP, CRM, BI
• Models, simulations and visualizations
• Asset management tools
• Design, legal and operating documents
• Research information

Qwaq Forums meets the needs of these dynamic, distributed environments, where successful work requires an ability to solve evolving problems.

Collaboration Features
• Content is easily shared by users and can be edited directly in the virtual workspaces by multiple users simultaneously
• Presence signals who is present and what they are working on
• Context is established through spatial arrangement of content and by linking virtual workspaces to each other
• Persistence of virtual workspaces makes content and applications available anytime for both group work and individual contribution

Architecture Highlights and Extensibility
Architecture highlights include:
• Scalable peer-centric architecture
• Built-in wide area VoIP, private and group text chat
• Built-in data traffic encryption
• Deployable behind-the-firewall server integrates with internal authentication services and provides privacy for sensitive data or applications (as an alternative to the Qwaq Forums standard hosted solution)
• Extensible using open standards. Runs on an optimized version of Croquet; supports scripting with Python

Powerful Features for Participants
Simple virtual workspace creation . . .
• Create meeting rooms, offices, and so on, from templates and link them together using drag-and-drop gestures
• Qwaq Virtual Campus™-a pre-built outdoor virtual space

Drag and drop content import . . .
• Share MS Office documents, PDFs, images, and so on, by dragging from local folders into a Qwaq Forums virtual workspace
• Hosted storage of drag-and-drop documents

Qwaq Multi-Share™ . . .
Fine-grained sharing control lets multiple users edit a document or use an application GUI in an intuitive manner. All users can see edits in real-time.
Presence . . .
Rich, real-time indicators of each user’s presence, including speaking/muted, idle time / away status, visual gestures such as yes/no and getting attention, and a user list similar to an IM buddy list. (See Understanding Presence.)

Example Uses of Qwaq Forums
Qwaq Forums can be leveraged in a variety of business, academic, entertainment and manufacturing environments. Just a few examples of current implementations are:

- Project execution, including group proposal creating, status review voice conversations, collaborative debugging, along with asynchronous individual contributions (analysis, review, incremental status)
- Distance learning, including directed coaching, software application lab, and foreign language practice, along with asynchronous individual contributions (self-paced tutorials for students and instructor annotations)
- Immersive simulation and visualization, including focus groups, hands-on training and mentoring, and operational asset management, along with asynchronous individual contributions (scenario planning, 2D and 3D modeling, and monitoring)

Participant, Administrator, and Developer Roles
Qwaq Forums enable cooperation at all levels. Some participants might play all roles at various times.

<table>
<thead>
<tr>
<th>Role</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Forum Participants, and Subject</td>
<td>Participants (typically field specialists or subject matter experts) and their audiences, inhabit and work in forums to accomplish any variety of tasks, including data analysis and manipulation, 3D modeling, research, and design. Qwaq Forums affords them a synchronized, collaborative, 3D experience in which to work.</td>
</tr>
<tr>
<td>Matter Experts</td>
<td></td>
</tr>
<tr>
<td>Content Developers</td>
<td>Content developers can build synchronized custom objects for Qwaq Forums. Objects built with Qwaq Forums share a common protocol that allows them to cooperate with each other. Content developers can add rooms/spaces and predefined objects from the menus, and use Python scripting tools to create custom objects.</td>
</tr>
<tr>
<td>Forum Administrators</td>
<td>Representative and point of contact for the organization using the forum(s). Submits requests and requirements to Enterprise Server Administrator for new forums. Manages forum users, including creating and distributing user names and passwords, and user access rights for linking and traveling between related forums. Maintains e-mail communication and in-forum bulletins to keep forum users up-to-date on events, meetings, and protocol pertinent to the organization’s forums. See also, Managing Forum Users (Forum Administrator Task) topic in this guide.</td>
</tr>
<tr>
<td>Enterprise Server Administrator</td>
<td>Manages Qwaq Forums Enterprise Servers, which host and maintain the Qwaq Forums applications for client organizations. Create and make available new forums at the request of Forum Administrators. See also, Enterprise Server Administrator Guide.</td>
</tr>
<tr>
<td>Application Developers</td>
<td>Qwaq and the Qwaq developer community work in Qwaq-provided Forums and create new ones with specialized, built-in features to support market-specific use cases.</td>
</tr>
</tbody>
</table>

All this allows separately developed multimedia and other rich content to be combined by cooperating users and developers into cooperating objects.
Template Forums
A template forum is a basic 3D collaborative space outfitted with a starter set of objects and functionality. Template forums include avatars and perspectives, 2D panels for displaying photos, video, and Web browsers, portal cards that provide links to other forums, and 3D projections that allow rich viewing of other spaces. Voice and text chat, sound, and lighting are included. Qwaq Forums comes with rich selection of template forums from which to build custom forums.

Template offerings are continually updated and added to, but here is a sampling of those currently available. Both indoor environments and outdoor landscapes are provided. All Qwaq Forums built based on the templates are “shared worlds” capable of hosting multiple participants for real-time collaboration.

- Campus
- Conference Room
- Gallery
- Office
- Personal Office
- Project Forum
- Sample Forum

For more about templates, see Working with Templates.

What Possibilities Do Forums Offer?
You can think of a single forum both as a “3D version of a Web page” (because you can use it to look at and work with information, and link to and from it to other forums) and as a “virtual space” (because of its 3D, collaborative characteristics, and built-in voice, live video, and text chat).

Forum participants can explore shared spaces and create new ones, navigate and manipulate a
variety of 2D and 3D objects, copy and modify objects, and upload their own content (a variety of media types including images, documents, slides, spreadsheets, and 3D models). Spaces are linked by portals or doors that allow instant jumps from one to another, and employ convenient properties that transcend physical world limitations. For example, “doors” to “rooms” can be carried around anywhere you go so that the space behind the door is instantly accessible no matter where you are in the model.

Participants can see each other and what they are doing in real-time. The result of your work is immediately available to all other participants, and theirs to you. Neither the users nor developers need to do anything special to make this happen.

All forums support share-able web browsing and bookmarks, annotation tools, voice over IP (VoIP), instant messaging, and other streaming media technologies in real-time.

As such, Qwaq Forums provide tools and template 3D environments for remote collaborative designing, modeling, exploring, building, teaching, exposition, and team conferencing.
Getting Started

All you need to get started working in Qwaq Forums is:

- **Membership Login** (username and password) – You can get a guest membership when you sign up for a trial, or full member login when you purchase Qwaq Forums. Please contact Qwaq ([http://www.qwaq.com/contact_us.html](http://www.qwaq.com/contact_us.html)) for login information if you do not already have it.


You can install and run on a Windows PC that meets system requirements noted below. Here is supported platforms information along with install and startup instructions.

Supported Platforms

The Qwaq Collaboration Platform and applications created with it are multi-platform environments that run as virtual machines on all platforms. The following standard platforms are supported in the initial release:

- Microsoft Windows, including Windows Vista
- Apple Mac OS, including Mac OS X 10.5 (Leopard)

System Requirements

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CPU</td>
<td>An Intel Pentium III processor or better is recommended. An Intel Pentium M processor with 1600 MHZ is more than adequate.</td>
</tr>
<tr>
<td>RAM</td>
<td>Systems with a minimum of 1GB random access memory (RAM) are preferred.</td>
</tr>
<tr>
<td>LAN and WAN</td>
<td>A network connection is required to access Qwaq Forums, which are hosted on servers remote from the clients. Both local area network (LAN) and access to a wide area network (WAN) are required for collaboration among multiple users.</td>
</tr>
<tr>
<td>Graphics Card</td>
<td>Qwaq Forums require a reasonable hardware graphics capability for rendering without excess network traffic or CPU load. Newer generation computers (less than two years old) are generally adequate to support Qwaq Forums. For systems older than two years, we recommend acquiring a new graphics card such as an NVIDIA GeForce 2 or better.</td>
</tr>
<tr>
<td>OpenAL and OpenGL libraries</td>
<td>See OpenAL and OpenGL Web sites to get these libraries:</td>
</tr>
<tr>
<td></td>
<td>• OpenAL information is available at <a href="http://www.openal.org/">http://www.openal.org/</a></td>
</tr>
<tr>
<td></td>
<td>• OpenGL information is available at <a href="http://www.opengl.org/">http://www.opengl.org/</a></td>
</tr>
</tbody>
</table>

Installing the Qwaq Forums Browser


Double-click the Qwaq Forums installer file to launch the installation wizard. (On Microsoft Windows platforms the installer file is `QwaqForums.msi`; on Apple Macs it is `QwaqForums.dmg`.)

Follow the steps in the Wizard. Accept the default install location: `C:\ProgramFiles\Qwaq\<application>` on Windows or Applications folder on Mac.
Starting the Browser and Joining a Forum

1. Start the Qwaq Forums Browser:
   - On a Windows Desktop, choose Start > All Programs > Qwaq Applications > Qwaq Forums.
   - On Apple Macs, double-click on the Qwaq Forums icon in the Applications window. This brings up a Login dialog.

2. Provide your User Name (based on your email) and Password.

3. Click Login. A successful login allows the list of forums and users to be displayed.

4. By default, the Forums tab is selected. It shows a list of available forums. (You can also click the Users tab, described in Listing Users.) You might have the option to log into forums in more than one organization, depending on the privileges associated with your login.
By default, Qwaq Forums uses a direct connection (no proxy) between the browser and the Qwaq Forums host. However, if your local machine is behind a firewall or secure gateway, you will need to configure proxy server settings to connect to forums on the Qwaq hosts. Qwaq Forums automatically prompts for proxy server settings if connection problems are detected. For more information, see the topic below on Proxy Settings.

5. Select a forum from the **Forums** menu.

   To view existing, pre-built forums, make sure **All Forums** is selected under “Show” options to the right of the list. (This is list is shown by default.)

   To view templates only, select **Templates** under “Show” on the right side of the list. Forums that are templates are shown in this format: **ForumName [Template]**. Select a template if you want to create a new forum. Otherwise select one of the pre-built forums.

   The number of users active in each forum or service is shown next to its name.

   If you choose a template such as “Sample Forum [Template]”, you are effectively creating a new space, so you are asked whether you want to generate a new minimal forum. Provide a name for the new forum (or accept the default name) and click **OK** to generate the new forum. Your new forum is automatically saved on the Qwaq host. (For more on this, see Creating New Forums from Templates.)

   If you choose a standard forum rather than a template, you will not get this question. The Forum will start loading the forum as soon as you click **Start**.

6. **Click Start.**

   - If you chose a **template**, the space is created for you as a new Sample Forum from the template at connection time.

   - If you chose a pre-built forum, you will be connected directly. If you or others have previously joined the forum and saved modifications, you will encounter a forum that is already somewhat customized. There can be multiple participants in a space simultaneously, and typically participants can save or discard changes (depending on permissions you define for the forum).

   Forum owners can define participant roles and authorization to modify objects and spaces. **Authorization** for some types of actions might rest with a role (for example, **Forum Administrators** might restrict entry to a subset of users as described in Managing Forum Users) while other types of authorization might be scripted into an object by **Content Developers** (for example, an object might be available for use by participants but not for modification). The Sample Forum template spaces you will start with have no such restrictions.

**Listing Users at Login**

On the login dialog, you have the option to list users as well as forums. Click the **Users** tab for a list of users. You can use this list to find out who is currently online (with Logged In option), and where they are (which forum). If users are online, you can right-click on a name to get an option to join them in the forum they are in.
For more about finding and joining users from within forums, see Finding and Navigating to Other Users.

For information on managing users if you are a Forums Administrator, see Managing Forum Users (Forum Administrator Task).

Creating New Forums from Templates
From the login dialog, you can create a new forum based on a template. To do this, follow these steps:

1. Click List Forums.
2. Select List Templates under “Show” on the left side of the login dialog. A list of available templates is displayed.
3. Select a template and click Start.
4. Accept the default name for the new forum or modify it, and click OK.

5. This starts a new forum based on the template you selected.

Note that you can also create new forums based on other forums, as described in Creating New Forums and Saving Changes.

Proxy Settings

By default, Qwaq Forums uses a direct connection (no proxy) between the browser and the Qwaq Forums host.

However, if your local system is behind a firewall or secure gateway, you will need to configure proxy server settings to connect to forums on the Qwaq hosts. Qwaq Forums automatically prompts for proxy server settings if connection problems are detected.

You can also open the Proxy Configuration dialog manually by right-clicking on any forum in the list and choosing Proxy Configuration.

To configure proxy server settings:

- Select the configuration mode
- Fill in the host and port information, or a proxy configuration URL as appropriate.
- Click Accept

To switch back to a direct connection, re-open the Proxy Configuration dialog and re-set the mode to “Direct Connection (no proxy)”.

An auto-detect option is also available to automatically switch settings to the appropriate connection type depending on the current network.
Online Help

Online Help for Qwaq Forums (this document) is available from the Help menu. Choose Help > User Guide to open the Help in a Web browser on your local system, external to Qwaq Forums. Help on various “quick reference” topics is also available from the Help menu.

The Help includes a clickable table of contents, index, and full-text search on tabs in the left panel.

- In Qwaq Forums, choose Help > User Guide to open the Help in an external Web browser. (In the Sample Forum, you can also view an in-Forum copy of the Online Help in a panel by choosing Places > Help Browser.)
- The Contents tab shows a list of Help topics. Click a topic to display it and show its subtopics. Click the “book” icon next to a topic to show or hide subtopics.
- Click the Index tab to get a clickable index. Click an index topic to display it. You can also click the alphabet links (A through Z) at the top of the Index panel to quickly navigate to index topics by alphabetical listing, then click the topic you want.
- Click the Search tab to get a full-text search of the User Guide.

In the Search field, type the word or phrase you are searching for and click Search. This will return a list of one or more topics that include your search entry (or a “not found” message if no references are found in the Help).

Next, click one of the topics then use the “find” feature in your Web browser to find the term on that Web page. For example, searching on the words “logging on” might return
At the top left of the main Help window, are buttons to show the TOC panel, and next/previous topic buttons:

- Click the **Show in Contents** button to view the Contents panel (if it is hidden)

- The **Next** or **Previous** buttons step through the Help topics sequentially. Click **Next** to view the next topic in the book, click **Previous** to view the previous one.

At the top right of the main Help window, buttons are provided to view the User Guide as a PDF or to print the displayed topic:

- Click the **PDF** button to view the User Guide as a PDF. (The PDF is in a “print-ready” document with page numbers in the TOC and Index.)

- Click the **Print** button to print the currently displayed topic. If the PDF is currently displayed, clicking Print will print the entire User Guide from the PDF. If a Help topic is displayed as a Web page, clicking Print will print that topic.

The buttons described above have flyover tooltips. Hover the cursor on a button to view its tooltip.

### Web Browser Popup Blockers and Security Warnings

Qwaq Forums Help is designed to display a Qwaq Web-hosted or local User Guide (as HTML and downloadable PDF) in your default Web browser. The User Guide and other documentation does not present a security risk in and of itself.

If you are using Windows Internet Explorer (IE) v.7 or above as your default Web browser, you might get an information dialog about blocked popups the first time you choose **Help > User Guide** from the menus. This is because the Help documentation employs scripts as a part of its Dynamic HTML deployment. To view the Help, you need to click **Close** on the informational dialog, then click the information bar at the top, choose **Allow Blocked Content**, and click **Yes** on the resulting dialog to confirm you want allow the dynamic Help Web pages.

To configure the IE Web browser to always allow display of Qwaq Forums Help pages, choose **Tools > Pop-up Blocker > Pop-up Blocker Settings**. In “Address of website to allow:” field, enter [www.qwaq.com](http://www.qwaq.com), click **Add** to add it to the list of “allowed sites”, and close the dialog.

If the Help is locally installed, the option to allow it will not be provided (since there is no HTTP address associated with it.) In this case, you will either have to click through the warnings each time or turn off pop-up blockers. *Turning off pop-up blockers can present a security risk.*

Generally, other Web browsers do not block these Help pages by default but if so, set preferences to allow pop-up windows from [www.qwaq.com](http://www.qwaq.com) in other browsers as needed.

### Quick Reference Help

In addition to the User Guide, the Help menu also includes Quick Reference Help topics on features such as navigation, sound and audio settings, importing content, and so forth. Choose **Help > <Quick Reference Topic>** to view the Quick Help. Click **More Information…** in the lower right corner of any Quick Help card to go to that topic in the User Guide.
In-Forum Help Documents

Some templates or sample forums might also include multi-media slide decks or tutorials that provide a product introduction, frequently asked questions (FAQs) or quick reference to using Qwaq Forums.

Setting Preferences

An avatar is a representation of you as a participant in the virtual space. Your experience of working with objects is mediated through your avatar and preference settings associated with your participant profile.

You can set various preferences with regard to display and behavior of the application. These include setting your screen name; the color and picture for your avatar, email address, profile details, point of view, sound settings, and so forth. (The color you choose for your avatar is also the color that will be used to indicate some of your actions in the space; for example, when you select an object or use the paint markup tool.)

To set preferences, choose Tools > Preferences to bring up the Preferences dialog. Configure your settings and click OK to save them.
Creating New Forums and Saving Changes

New forums are automatically saved to the hosted server when you first create them. To save subsequent changes you make to the current forum:

- Choose **File > Save** to save changes and overwrite the last state of the current forum. This uploads and saves the forum on the Qwaq host. All changes made by participants are saved including new, modified, or uploaded content, object re-arrangement, notes, and so forth.

- Choose **File > Save Copy As** to create a new forum based on the current one. (From a template forum, this is the only “save” choice available since users cannot modify the templates.)
• Choose **File > Save As Template** to create a **forum template** based on this forum.

• Choose **File > Save All** to save changes to the **current forum and all other forums you added or modified in this session**. All changes made by participants are saved including new, modified, or uploaded content, object re-arrangement, notes, and so forth.

### Working with Templates

Templates are ready-made forums built around project themes such as an office, a gallery, a campus, and so forth. We provide you with some standard templates with which to start your first forums.

Also, you can save your own forums as custom templates (starting points for future forums). Typically, user-created templates are added to the library of shared templates available to an organization. (This might vary depending on permissions and security associated with your projects.)

- For information on how to create a forum based on a template at login, see Creating New Forums from Templates under Starting the Browser and Joining a Forum.
- For information on saving the current forum as a template, see Creating New Forums and Saving Changes.

### Managing Forum Users (Forum Administrator Task)

A **Forum Administrator** is the point-of-contact for their organization. They may handle several forum-related tasks including submitting requests to the server administrator for new forums, handling Qwaq Forums software version upgrades, and providing communication to users about upcoming forum events.

A Forum Administrator’s key task is forum user management, for which they have administrator-level permissions. Forum Administrators can add new users, delete users, manage usernames and passwords, and allow or disallow user login permissions to their forums. They can also grant other users administrator-level permissions in selected forums.

There are two different ways to get to the Manage Users dialog for a forum.

- If you log in as an administrator to the forum you want to manage, the user list is available from the **People** panel—a docked panel in the upper right of the forum that provides lists users and highlights those who are currently in the local forum. Right-click on the user list to get a **Manage Users** option to display the user management dialog for the local forum. (Or use the **Extras > Manage Users** menu command to go directly to the user management dialog.)

- From within any forum (if you are logged in as the forum administrator) bring up a list of forums and right-click on a forum, the **Manage Users** option opens the user management dialog for the selected forum (even if it’s different from the forum you are currently in). To get this option, you must be the administrator for the selected forum.

### Manage Users for Local Forum

1. Log in to the forum for which you want to manage users.

2. Select any user in the list on the **People** panel, right-click, and choose **Manage Users**.
This brings up the Forum Users management dialog for the local forum. The name of the forum is shown on the title bar of the dialog. (For example, the forum name in the example picture below is “Docs Sandbox 1.1.6”)

Manage Users in a Remote Forum
1. Choose Forums > All Forums or Tools > Forums to bring up a list of available forums.
2. Right-click a forum for which you are an administrator, and choose Manage Users.
This brings up the Forum Users management dialog for the selected forum. The name of the forum is shown on the title bar of the dialog. (For example, the forum name in the example picture below is “Next Forum”)

**User Management Options**

A right-click on a name in the Forum Users dialog provides options:

- Allow or disallow all users in this forum
- Add a new user
- Delete the selected user
- Change the password for the selected user

To move selected users from the Organization list to the Forums list, click the right arrow button. To move selected users out of the Forums list (disallow), click the left arrow button.

**Deleting Forums**

To delete a forum, you must be logged in to a forum. We suggest logging in to a forum other than the one you want to remove.

1. Log into a forum other than the one you want to remove.
2. Choose **Forums > All Forums** or **Tools > Forums** to bring up a list of available forums.
3. Select the forum you want to remove, right-click, and choose **Delete Forum**.

**Renaming a Forum**

There is no rename option per se. To rename a forum, use the **File > Save Copy As** option and then delete the old forum.

**Logging Out and Quitting**

To log out of a forum and/or quit the Qwaq Forums browser:

- Choose **File > Log Out** to log out of the current forum and return to the login window.
- Choose **File > Exit** to log out of the current forum and close the Qwaq Forums browser.

If you have unsaved changes, a Save Changes confirmation dialog asks whether you want to save or discard your changes. (You can also choose **File > Quit Without Saving** from the menus.)

**Navigating**

The Qwaq platform is designed to support any number of different user interfaces. The demo applications provided are representative top-level user interfaces leveraging a number of Qwaq tools and features. Individual objects in the space can define their own interfaces.

The following sections describe how to interact with the Qwaq applications via their interfaces; but bear in mind that these interfaces are implementations of the Qwaq Collaboration Platform. Your organization can choose to leverage the Qwaq platform to develop an entirely different model, including a different UI if desired.

**Starting Position and Avatars**

After logging into a space, you are presented with a 3D view of the current space. The look-and-feel of your starting position may vary depending on the forum, but generally you will be in the center of the primary space.
In the case of the Sample Forums, the space is a conference room with maps, white boards, file systems, 3D projections, rolodexes of 2D and 3D portals, and other starter kit objects.

An **avatar** is a representation of you as participant in the virtual space.

Your experience of working with objects is mediated through your avatar and preference settings associated with your participant profile.

Depending on the settings at startup, this icon or picture representing you may or may not be visible to you. In “First Person” point of view *(Tools > Point of View)* your avatar is not visible to you.

You can set other options related to your avatar via the **Tools > Preferences**, including the name displayed above your avatar (which is visible to others depending on their own settings), your avatar color, whether to show screen names, and so forth.

Other participants are represented by their avatars.
You can use the Avatar menu to adjust your viewpoint (first person, near, normal, or far), to change colors, and upload/insert different pictures or icons for your avatar. If there are other users in the space, you will see their avatars as well.

When you are manipulating objects in the space, your actions are indicated with a highlight color which matches your avatar color. This provides a visual cue for you and other participants about who is working with which objects at any time. Generally, only one participant at a time can edit an object.

Wearing a Badge
Your avatar can wear an image as a “badge” to further identify yourself as affiliated with some interest or community. Options to add or clear a badge are available on My Avatar dialog. Choose Tools > My Avatar to bring up this dialog.

Select Browse to bring up a local file browser where you can select an image for your badge. When you select the local file, it is automatically imported into Qwaq Forums and set as your badge. (For more information about importing images, see Importing Your Content.)

You might want to keep your favorite badges in a handy rolodex in your in-Forum “office”.

To remove the badge, select Clear.

The My Avatar dialog also provides options to select your face picture and shape. (See also Setting Preferences.)

Moving Around in the Space
You can move around in the space by using the tools on the Navigation panel at the bottom of the screen or via mouse and keyboard controls. If your avatar is set to visible mode, you will see it traveling immediately in front of you.
Qwaq Forums spaces have two modes:

- **Navigation mode** – Drive mode. To return to this mode (and get out of Edit mode) press Esc key or click on the keyboard icon in lower left of Forum window.
- **Edit mode** – Activated when you click into a document or Web page.

In order to navigate and move any distance in the space (with Navigation buttons, mouse, or keyboard commands), you must have Navigation mode enabled (not Edit mode). For navigating with keyboard or mouse, you must also have the cursor within the boundaries of the space (not outside of it on the Navigation panel).

Both modes are described in more detail in the next topic, Navigation Panel, See also Edit Mode and Navigation Mode in Manipulating 2D Objects in Panels.

**Navigation Panel**

The navigation panel shows your position in the space. To bring up the navigation bar, hover the cursor near the bottom of the forum window, just above the toolbar. (A transparent, lighter color rectangle on the bottom center of the screen is a hint as to where to get the navigation panel.)

(In order for the navigation panel to be displayed, “Show Dashboard” must be enabled in Tools > Preferences.)
The following table describes Navigation controls on the toolbar below the view space. Note that most are controls for moving your avatar through the space, but some are gages such as the compass to indicate your heading. Most actions have keyboard commands alternatives as well.

<table>
<thead>
<tr>
<th>Navigation Control</th>
<th>Description</th>
<th>Keyboard Option</th>
</tr>
</thead>
</table>
|                    | Indicates **Edit mode** is enabled, and **Navigation** (or Drive) mode is temporarily disabled. Edit mode is enabled when you click in a Web browser or text file. The keyboard “edit enabled” indicator shows up to the left of the navigation panel only when Edit mode is enabled.  
In Edit mode, your keyboard and mouse respond as input devices to Web browsers or text files.  
To get out of Edit mode and return to navigation mode, simply move the cursor out of the current Web browser or text file area, click into the space, and navigate as usual. You can also press the Escape key (Esc) on your keyboard to exit Edit mode.  
For more information, see Edit Mode and Navigation Mode.                                                                 | • Esc – exit Edit mode, return to Navigate (Drive) mode  
Or  
• Left mouse-click on the keyboard icon in lower left of Forums window to exit Edit mode and return to Drive mode. |
|                    | Compass that indicates your direction relative to True North in the virtual space. It indicates the direction in which you are moving or facing (if stationary).                                                                                   |                                                                                 |
|                    | Turn to face north.                                                                                                                                                                                          |                                                                                 |
|                    | Controls for moving forward, backward, left or right (as an alternative to the mouse button controls). Click and hold on one of the arrows to move in the direction of the selected arrow.  
The middle button centers your avatar in the middle of the primary room or space. You can always use this to return or “reset” to starting position in the current space. | • W – go forward  
• S – go backward  
• A – turn left  
• D – turn right  
• Q – go (sidestep) left  
• E – go (sidestep) right  
Or use Arrow keys:  
• Up arrow key – go forward  
• Down arrow key – go backward  
• Left arrow key – turn left  
• Right arrow key – turn right  
Home – Reset to star position |
<table>
<thead>
<tr>
<th>Navigation Control</th>
<th>Description</th>
<th>Keyboard Option</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Turn to the left. You can also use keyboard command “Q” to move to the left.</td>
<td>A or left Arrow key Q goes left in sideways motion</td>
</tr>
<tr>
<td></td>
<td>Turn to the right. You can also use keyboard command “E” to move to the right.</td>
<td>D or right Arrow key E goes right in sideways motion</td>
</tr>
<tr>
<td></td>
<td>Accelerates movement in any direction. Hold shift key down while pressing a navigation control or key to go forward, backward, left, or right at an accelerated rate.</td>
<td>Shift key – speed accelerator</td>
</tr>
<tr>
<td></td>
<td>Look upward. (Tilts perspective to looking up at the space from below.)</td>
<td>C</td>
</tr>
<tr>
<td></td>
<td>Note: Driving with the right-mouse button resets viewing angle to horizontal; driving with keyboard commands does not.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Look downward. (Tilts perspective to looking down at the space from above.)</td>
<td>R</td>
</tr>
<tr>
<td></td>
<td>Note: Driving with the right-mouse button resets viewing angle to horizontal; driving with keyboard commands does not.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Reset the viewing angle to horizontal. (Undo tilted perspective.)</td>
<td>F</td>
</tr>
<tr>
<td></td>
<td>Move upward vertically (jump or fly), where possible.</td>
<td>Up arrow.</td>
</tr>
<tr>
<td></td>
<td>Move downward vertically (from a jump or in-flight).</td>
<td>Down arrow.</td>
</tr>
<tr>
<td></td>
<td>Press/release the Tab key several times to move to named places in the space. Shift-Tab moves to each named space in reverse order. (See Actions &gt; Name this Place menu option description in Finding Objects.)</td>
<td>Tab – Go to next placemark. Shift-Tab – Go to previous placemark.</td>
</tr>
</tbody>
</table>

**Mouse Navigation**

Only a keyboard and mouse are required to interact with the applications. Three-button mice are supported, although the default interface makes uses of two, which we name the “manipulation” and “navigation” buttons.

Keyboard modifiers enable the use of mice with only a single button.

The Navigation button depends on the operating system on which the Qwaq application is running. To start mouse navigation on any platform, press, hold, and drag the mouse in the direction you want to go to initiate movement of the avatar.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
</table>
### Key Action

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows</td>
<td>Right-click (Press, hold, and drag the right mouse button.)</td>
</tr>
<tr>
<td>Mac</td>
<td>Option-click. (Hold down the option key and then press, hold, and drag the mouse button.) If you have a three-button mouse, you can also press the right mouse button.</td>
</tr>
</tbody>
</table>

To move around in the space, press, hold, and drag the navigation mouse button within the application window, at some distance from the center of the window. The closer your mouse is towards the top, the faster you move forward. The closer your mouse is towards the bottom, the faster you move backwards. Similarly for turning left or right. If you also hold down the shift key, you will look up and down rather than moving forwards or backwards, respectively.

You can use the scroll wheel on the mouse to get a **zoom in/out effect**. Dial the mouse scroll bar away from you to zoom in or towards you to zoom out. (This is actually moving the avatar closer to or farther from the target object or area, but especially in first person point of view, effectively works like a zoom.)

**Keyboard Navigation**

Keyboard controls are available for most navigation options. Standard gaming mappings are provided. These are listed along with associated Navigation Panel control in the table above, but also shown here again for quick reference.

Note that in order to move through the space, you must be in **Navigation mode** (as indicated by the geo-positioning information in the Navigation panel) not Edit mode, and you need to keep the cursor within the boundaries of the current forum space.

<table>
<thead>
<tr>
<th>Keys</th>
<th>Arrow Keys</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>W</td>
<td>Up</td>
<td>Go forward.</td>
</tr>
<tr>
<td>S</td>
<td>Down</td>
<td>Go backward.</td>
</tr>
<tr>
<td>Q</td>
<td>Left</td>
<td>Go left.</td>
</tr>
<tr>
<td>E</td>
<td>Right</td>
<td>Go right.</td>
</tr>
<tr>
<td>A</td>
<td></td>
<td>Turn (look) left.</td>
</tr>
<tr>
<td>D</td>
<td></td>
<td>Turn (look) right.</td>
</tr>
</tbody>
</table>
| C    |            | Look up. Tilts perspective to looking up at the space from below.  
**Note:** Using the mouse keys to drive resets viewing angle to horizontal. |
| R    |            | Look down. Tilts perspective looking down at the space from above.  
**Note:** Using the mouse keys to drive resets viewing angle to horizontal. |
| Shift|            | Accelerates movement in any direction.  
Hold shift key down while pressing a navigation control or key to go forward, backward, left, or right at an accelerated rate. |
| Alt  |            | Slows movement when used in combination with other navigation keys.  
Hold down the Alt key and while pressing another key like W, S, A, D, E, Q, arrow keys, or C/R keys to move slowly.  
This is a good way to achieve fine control of motion; for |
### Keys

<table>
<thead>
<tr>
<th>Arrow Keys</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Tab key cycles through all available places in the forum.</td>
</tr>
<tr>
<td>End – Bird’s Eye</td>
<td>This includes built-in places (Center, Bird’s Eye, Text Editor, and Help Browser) as well as new places you create with the Actions &gt; Name this Place menu option.</td>
</tr>
<tr>
<td>Home - Center</td>
<td>End key gives you the Bird’s Eye view. Home key takes you to the center of the space.</td>
</tr>
</tbody>
</table>

See also keyboard commands related to Gestures for Simple Communication.

### Go Back/Next to Previously Visited Forums

The Back and Next buttons on the upper right of the Qwaq Forums window act like back/next history buttons in a Web browser. Click the back button to jump back to the last forum you were in, or next to go to your more recent forum location. Like a Web page history, you can use back/next to toggle through a history list of forum locations. (Tools > History shows the list of visited forums; or press and hold either the back or next button to get that same list.)

### Finding and Navigating to Other Users

The user list is available from the People panel—a docked panel in the upper right of the forum that provides lists users and highlights those who are currently in the local forum. The User List includes some right-click options for finding users in forums and navigating within or across forums to join them. The “turn to” option is a physical cue for starting a dialog with someone in close proximity. The “go to” option is a good way to find someone in the current forum or even in another forum. The “go beside” option is useful for finding someone in a crowd.

These options are available only when there are other users online and, for “turn to” or “go beside”, present in the same forum.

- To find and navigate to users, start with the user list shown in the People panel.
- To navigate to the same location as another user, right-click a user name in the list and select Go To. (Or select the user name and click the “go join the selected user” button.)
- To navigate to and stand beside another user—and stick with them in their travels, right-click a user name in the list and select Go With. (Or select the user name and click the “go stand beside the selected user and tag along with them” button.)

Note: Tables can be used organize users in a group. Place a table in a room (menu command Objects > Furniture > Table), and have users go to your location. The avatars will automatically take an open place at the table, facing each other. (See Working with Content for general information about adding and working with objects like tables.)

The People user list also shows whether a user is online and in which forum.

Similarly, you can find users at login. The Users tab on the Login dialog, shows all users, indicates who is currently online, and who is in which forums. For more information on this, see Listing Users at Login.

For information about communicating with other users, see Communicating with Voice and Text Chat. For information about working with users as an administrator, see Managing Forum Users (Forum Administrator Task).
Gestures for Simple Communication

In addition to using keyboard commands for driving around (navigating), you can also use keyboard commands to invoke simple gestures on your avatar. The following key commands (in driving mode, not input-typing mode) invoke the gestures described.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacebar</td>
<td>Jump up and down, or wave to get (or acknowledge) attention</td>
</tr>
<tr>
<td>Y</td>
<td>Nod your head “yes” (up and down)</td>
</tr>
<tr>
<td>N</td>
<td>Shake your head “no” (side-to-side)</td>
</tr>
<tr>
<td>B</td>
<td>Short bow of the head</td>
</tr>
</tbody>
</table>

Setting Present or Away Status

You can set your status as “away” so that other Forum participants will know you are not available.

Click the “present/away” status button on the toolbar to toggle between the two settings. When you are “away”, the tool button shows a blank screen, voice chat is suspended, and your “away” status shows in the user list. Click the same tool button again to revert your status to “present” and resume voice chat.

Communicating with Voice and Text Chat

Qwaq Forums provide several ways of communicating with other participants. The two most direct ways are via text and voice chat. The following topics describe these features, along with various sound settings, which are integral to voice chat.

(For information on other ways to communicate, see Finding and Navigating to Other Users, Gestures for Simple Communication, and Setting Present or Away Status.)

Text Chat

A Text Chat window is available in the upper left of the forums window. To start a text chat with others in the space, click in the Text Chat input field and start typing. Hit Return to send the message. If the Text Chat window is not showing, you can bring it up by choosing Tools > Text Chat from the menus, or simply by hitting Enter key (or Return) on your keyboard.

Text Chat here works similar to a conference instant messenger; all forum participants can participate in the conversation by viewing and sending messages in their Text Chat window.

Right-click on upper part of the Text Chat window to get these command options:

- **Show More Messages** – Uploads more, older messages into the chat panel in batches of 40 up to a maximum of 240 messages. Click once to upload the last 40 messages not previously shown, again to add set of 40 older messages, and so on.

- **Save Transcript** – Saves a transcript of the current conversation to a specified file.

Right-click on the chat text entry field (lower part of the Text Chat window) to get a set of Text Chat edit options, including Find, Undo, Redo, Copy, Cut, Paste, and so forth.

Hover the mouse over a chat message or enter/exit message to get the associated timestamp. This lets you monitor the timeline of a conversation and arrivals and departures of participants even if you weren’t in the forum during some of the activities.
If the Text Chat window is closed and another user enters a message, you will hear a high-pitched beep as a signal that you might want to open the window.

You need to manually open the Text Chat window; it does not open automatically when a user enters a message, but rather is left under your control.

Private Text Chat
Text chat from the main Text Chat message window is viewable and available to all participants. If you would like to have a private conversation with a user, bring up the User List (People > All Users menu option), select the name of the user with whom you want to dialog, and click the “private text to selected user” button. A separate, private text chat window is provided for a one-to-one conversation with this user.

Audio Conferencing and Sound
Audio conferencing or “voice chat” via Voice over IP (VoIP) is built in to all Qwaq Forums. If you want to participate in voice chat, the computer you are using must be equipped with:

- a microphone (built-in or external), properly configured
- speakers (that you listen to directly or through headphones)

A common setup is to use headphones that include an external microphone.

When your microphone is on, other participants can hear you when you are talking. If you mute your in-forum microphone but leave sound on, you can still hear other participants and sounds in the space but they cannot hear you.

Since audio conferencing and sound effects are key ingredients for the success and richness of your Qwaq Forums experience, we recommend spending a little time at the start to verify your system sound setup, and conduct quick sound checks both external to and within Qwaq Forums.

External Component and Software Sound Check
First, make sure that your computer hardware, microphone, speakers, and sound system settings are properly connected, configured, and working outside of Qwaq Forums.

Before launching Qwaq Forums, configure and test microphone and sound settings. How you access these settings depends on your platform and operating system version. Following are two common examples for a Windows PC and Apple Mac.

If you need to reset system sound settings while Qwaq Forums is running (for example, if you plugged in headphones after starting Forums), you will probably need to reset sound in the forums after. From the Qwaq Forums menus, choose Extras > Reset Sound or Tools > Sound and click Reset Sound, then click OK.

Microsoft Windows XP Sound Check
Right-click the Volume audio icon in the System Tray and choose Adjust Audio Properties to bring up the “Sounds and Audio Properties” dialog. If the Volume icon is not showing on the system tray, click the arrow to expand the view of options in the tray. (You can also choose taskbar Start > Control Panel > Sounds, Speech, and Audio Devices > Sounds and Audio Devices to bring up the Sounds dialog.)
On the “Sounds and Audio Properties” dialog, use these controls to configure and test sound components:

- Click the **Volume tab**, and make sure the **Mute** option is off/disabled (unchecked) and the **Volume slider** is set “high” enough. Click-and-drag the Volume slider closer to High to increase your output volume. (The settings on the Volume tab affect your “output” volume and determine whether others can hear you.)

An external headset (headphones and microphone) usually shows up as an additional device on this and other tabs, but not always. The system can default to show built-in speakers and audio, and still use input and output from the headset.

So, if you are using a headset and but don’t see it displayed on these dialogs, still continue with the checks that follow both in and outside of Qwaq Forums to verify if you can hear and be heard.

If you find that your headphones and microphone are not working, then work back through these configuration topics again, and see if you can get the system to recognize the device.
• Click the **Voice** tab, and set/test the voice playback (output for speakers/headphones) and voice recording (input for microphone) default devices and volume levels. (Voice tab settings will typically be the same as Audio tab but it is good to check the settings.)

To bring up Sounds and Audio Devices Properties dialog on a Microsoft Windows system, choose taskbar Start > Control Panel > Sounds, Speech, and Audio Devices > Sounds and Audio Devices or simply right-click on the "Volume" audio icon in the System Tray and choose Adjust Audio Properties.

1. If Sounds and Audio Devices Properties dialog is not already displayed, right-click the Volume audio icon in the Windows System Tray and choose Adjust Audio Properties, then click the Voice tab.
2. On the Voice tab, click Test hardware button to start the wizard, and click Next.

• Run the **Test hardware**... wizard from the Voice tab to test both sound input and output.
3. Wait for the wizard to discover and test your sound hardware. This takes a few moments.
4. On the Microphone Test dialog, follow the instructions to test your microphone.

5. On the Speaker Test dialog, follow the instructions to test your speakers or headphones. Click **Next** after you have tested both Recording (input) and Playback (output).

6. To complete the test and exit the wizard, click **Finish** on the last screen (not shown here).

   ![Sound Hardware Test Wizard](image)

After setting the all sound settings on Sound and Audio Devices Properties dialog, be sure to click **Apply** or **OK** to save your new settings.

Re-test whether your devices are working. If, for example, you were trying to configure sound output through external headphones; put on your headset, press-and-hold (left-click) the volume icon in the Windows system tray, and use the slider to change the volume. You should hear a beep in your headphones when you change the volume. If you do not hear the beep in the headphones (but only through the built-in speakers) then the system isn't accepting the device change yet. Try again, or reboot.
Apple Mac OS X Sound Check

From the Apple menu ( ), choose System Preferences, and click Sound to bring up the Sound dialog.

- Click Output and choose the appropriate device for sound output. Make sure Mute is disabled (unchecked), and check the output volume by moving the control bar and listening for the test sound.

- Click Input and choose the device you want to use for sound input (either built-in microphone or other). Speak into the input device and verify the microphone is picking up your voice by monitoring the input level bar. Adjust the input volume as needed. (We recommend keeping the input volume low to prevent distortion others might hear when you are speaking.)
### In-Forum Microphone and Speakers

Qwaq Forums tool buttons for the sound-related controls are shown here. (See toolbar at bottom of Forum window.)

<table>
<thead>
<tr>
<th>Sound Control</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Mic always on" /></td>
<td>Microphone on/off for audio conference with other participants. When the microphone is toggled on and working properly, it shows a green sound level (&quot;VU&quot; meter) to indicate input level when you are talking. The more green you see, the louder/stronger is your input.</td>
</tr>
<tr>
<td><img src="image" alt="Use Push-to-Talk" /></td>
<td><strong>The microphone is off (muted) by default</strong> every time you start Qwaq Forums. Click the microphone tool button to toggle it on or off (mute). Also, you can use the F1 key to turn the microphone on and off. (On laptops, you may need to press a two-key chord “Function” + “F1” since plain F-keys are often bound to hardware adjustments like screen brightness.) The microphone also includes a <strong>“Push-to-Talk”</strong> mode. When this is on, you must press the Ctrl key on your keyboard to be heard. Right mouse-click on the microphone icon to get an in-Forum menu for microphone options, or choose <strong>Tools &gt; Sound</strong> for the Sound Levels dialog.</td>
</tr>
<tr>
<td><img src="image" alt="On Full-Time" /></td>
<td>Right-click mic icon to get this options menu. For full details, see In-Forum Microphone and Speakers.</td>
</tr>
<tr>
<td><img src="image" alt="Speaker on/off" /></td>
<td>Speaker on/off for sound from the application. Click the speaker tool button to turn it on or off. This activates or mutes sound effects in the space, and also sound for voice chat. When the speaker is on, you should be able to hear forum sounds including the conversation of other participants. To re-set speaker volume up or down, choose <strong>Tools &gt; Sound</strong> for the Sound Levels dialog. See also In-Forum Microphone and Speakers for complete information.</td>
</tr>
</tbody>
</table>

### In-Forum Sound Check

Make sure that your microphone and speakers are on when you want full audio-conferencing enabled. (As in phone conferences, mute or un-mute your microphone as needed.)

Qwaq Forums provides several sound control and testing utilities to help you modulate audio, and verify that in-forum input and output audio-conferencing is working in your client.

From a forum menu, choose **Tools > Sound** to bring up the Sound Levels dialog. Set options as described below, then click **OK** to apply and save your settings. Input settings are remembered between Forums sessions.
The Sound Levels dialog provides the following options:

- **Volume** – Adjusts the speaker volume (output) for your computer. Use the mouse to click-and-drag the bar up for louder speaker output, or down for softer output.

- **Input Level** – Adjusts the microphone volume (input) for your computer. Drag the bar up to make your microphone input louder, or down to lower your input volume.

- **Noise Filter** – Adjusts the volume filter to reduce hiss as needed for your computer and audio equipment.

- **Use Push-to-Talk** – Enabling this option causes your Qwaq Forums microphone to be live (active) only while the keyboard Ctrl key is depressed.

When “Use Push-to-Talk” is set to “on” (enabled), the microphone on the Forums toolbar shows a “blocked” bar and if you scroll over the icon, the on-screen tips indicate you must “press Ctrl key to talk”. (Qwaq Forums needs keyboard focus for Ctrl key to work.) To toggle the “Push-to-Talk” option on or off either go through this dialog and save changes, or from the main Forum UI, right-click the microphone icon in the toolbar until its menu appears.

When “Push-to-Talk” is set to “off” (disabled), the microphone on the Forums toolbar does not include the “blocked” bar. When you are talking or providing other sound input, your level is indicated by the green fill in the mic. (The louder your input, the more green.)

- **Hear Myself (Temporary)** - Sound check utility for voice chat. Toggle this option on to you hear yourself as others hear you. Normally, your own voice is not played back in your client. By default, this option is off. (This setting is also available in the Extras menu.)

On some computers, you will still need to check or some adjust settings through the native system control panel. For details, see External Component and Software Sound Check.

**Note**

- To view or change sound options on a Windows XP system, right-click the Volume audio icon in the Windows System Tray and choose Adjust Audio Properties to bring up the Sounds and Audio Devices Properties dialog. (See Microsoft Windows XP Sound Check for details.)

- To view or change sound options on a Mac, choose Apple menu > System Preferences and click Sound. (See Apple Mac OS X Sound Check for details.)
From a forum menu, choose **Extras > <SoundControl>** where `<SoundControl>` is one of these options:

- **Hear Myself** – Sound check utility for voice chat. Toggle this option on to you hear yourself as others hear you. Normally, your own voice is not played back in your client. By default, this option is off.

- **Reset Sound** – Troubleshooting option for resolving sound problems. Choose this option to reset the sound link between your Qwaq Forums client and operating system.

- **Test Built-in Sound** – Sound check utility for in-forum audio. Toggle this option on to play a forums-generated test sound repeatedly. Toggle off to stop the sound.

- **Test Spatialized Sound** - A sound check utility for in-forum audio. Toggle this option on to play a forums-generated, spatialized test sound repeatedly. Toggle off to stop the sound.

- **Test Voice Transport** – Sound check utility for debugging microphone problems, this tests everything used by "Hear Myself", except the microphone. Select this option to play a prerecorded voice saying "Testing voice chat" that everyone will hear as if you spoke it. (You will not hear it unless you have "Hear Myself" turned on.) If others hear the test message but do not hear you when you speak, something is probably wrong with your microphone.

### Sound/Audio Status of Other Users

The User List includes indicators that show the audio status of all users in the current forum. There are indicators on each user for:

- **Idle** - The user has not used mouse, keyboard, or voice for more than 1 minute

- **Mic Off** - The user’s sound input is disabled. (They haven’t turned on their sound input.)

- **Sound Problem Indicator (!)** - The user has a connection problem or network delay

- **Sound Level** - When the user speaks, sound level indicators are shown to all participants.

### Troubleshooting Common Sound Problems

<table>
<thead>
<tr>
<th>Problem</th>
<th>Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>One or more users hear heavy static in the forum</td>
<td>Participant(s) who hear the static can:</td>
</tr>
<tr>
<td></td>
<td>• Click <strong>Reset Sound</strong> in Qwaq Forums (Tools &gt; Sound)</td>
</tr>
<tr>
<td></td>
<td>• Check if they have other programs running locally that overload processing and audio. (For example, running Skype and Qwaq Forums at same time would give trouble.)</td>
</tr>
<tr>
<td></td>
<td>• Check to see if your CPU is running near or at 100% because other programs are using up CPU resources. This can interfere with microphone processing. If so, stop those other programs, click <strong>Reset Sound</strong> (in Tools &gt; Sound), and see if the sound improves.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Other users cannot hear one particular user speaking</th>
<th>Participants can check the Users list to see if a sound level icon is showing next to the speaker's name . . .</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>• If so, all other users should click <strong>Reset Sound</strong> (in Tools &gt; Sound)</td>
</tr>
<tr>
<td></td>
<td>• If not, then the problem is with sound settings on the speaker’s system. The speaker should (1) verify that their microphone is working (via system controls outside of Qwaq Forums) and (2) perform sound checks in Qwaq Forums (Tools &gt; Sound options for <strong>Reset Sound</strong> and <strong>Hear Myself</strong>).</td>
</tr>
<tr>
<td></td>
<td>• If the Users list shows that the speaker is muted, tell them to unmute.</td>
</tr>
<tr>
<td></td>
<td>• If the speaker is in <strong>Push-to-Talk</strong> mode but they complain that holding down the control key does not activate their microphone, the problem</td>
</tr>
</tbody>
</table>

<http://www.qwaq.com>  
Forums v. 1.1.77
<table>
<thead>
<tr>
<th>Problem</th>
<th>Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Could be that Qwaq Forums does not have keyboard focus. Qwaq Forums must be the active application on the desktop for this to work. If the user (speaker) has another application active (email, Web browser), Forums will not receive the Ctrl-key command.</td>
<td></td>
</tr>
<tr>
<td>Participants notice intermittent drop-outs of one user's sound (voice) input</td>
<td>The speaker whose voice is dropping out occasionally should try the following:</td>
</tr>
<tr>
<td>• In Qwaq Forums, choose Tools &gt; Sound and adjust the noise filter (lower it)</td>
<td></td>
</tr>
<tr>
<td>• Raise the input volume on the microphone in the system controls</td>
<td></td>
</tr>
<tr>
<td>• Click <strong>Reset Sound</strong> in Qwaq Forums (Tools &gt; Sound)</td>
<td></td>
</tr>
<tr>
<td>• Check for other applications or processes that might be overloading CPU processing</td>
<td></td>
</tr>
<tr>
<td>Several users have sound drop-outs (erratic sound for all)</td>
<td>If several participants are experiencing sound issues, the problems are probably due to high network traffic or network instability.</td>
</tr>
<tr>
<td>• Check if most users are operating over poor wireless connections. Qwaq Forums requires a strong signal; if your wireless network indicator shows a weak signal, this can interfere with sound and audio processing.</td>
<td></td>
</tr>
<tr>
<td>• If multiple users are sharing the same wireless network, this can cause these problems</td>
<td></td>
</tr>
<tr>
<td>User hears an echo</td>
<td>Whoever is hearing the echo is <strong>not</strong> the source of the problem. Usually another user is letting their microphone pick up the sound of open speakers, which causes the other users to hear themselves. The user who is causing the echo (who is probably not using a headset) needs to make some adjustments. Some solutions are:</td>
</tr>
<tr>
<td>• Switch to a headset, so the sound of the other users will not be heard by the microphone</td>
<td></td>
</tr>
<tr>
<td>• Use <strong>Push-to-Talk</strong> Qwaq Forums option, so that most of the time the microphone is not picking up the speaker output</td>
<td></td>
</tr>
<tr>
<td>• Use an echo-canceling speakerphone attached to your computer. (For recommendations, see the Qwaq web <strong>Support Portal</strong> or the Resources page at <a href="http://www.qwaq.com/resources/">http://www.qwaq.com/resources/</a>.)</td>
<td></td>
</tr>
<tr>
<td>Speeded-up, distorted voices and sound</td>
<td>Speeded-up or distorted sound is typically the result of system overloads either in or outside of Qwaq Forums. Check to see if:</td>
</tr>
<tr>
<td>• Session users are doing operations in the forums that are overloading the system (like uploads, imports, or saves of the forum)</td>
<td></td>
</tr>
<tr>
<td>• Users' computers are doing background downloads or uploads on other applications like Web browsers</td>
<td></td>
</tr>
<tr>
<td>Try to limit process-intensive activities during meetings if you determine they are causing sound problems. Speed-up can also occur when Qwaq Forums intentionally accelerates to catch up a user after a brief network delay. In such cases, the speed-up generally lasts no more than 30 seconds, after which time the client should be back in sync and sound quality returned to normal.</td>
<td></td>
</tr>
</tbody>
</table>

For the latest information and tips about audio and voice-over-IP (VOIP), please see the Qwaq web **Support Portal** or the Resources page at [http://www.qwaq.com/resources/](http://www.qwaq.com/resources/).
Understanding Presence

Voice and text chat tools, options on the People panel, along with various message indicators, expresses the presence of each user in a forum. The following diagram provides a quick glance at tools and indicators that communicate presence.

Importing Your Content

You can import a variety of file types from other applications into Qwaq Forums.

To import a file, do either of these:

- Choose File > Import from the menus and use the file browser to select the file you want to import and click Open.
Or

- Simply drag-and-drop the file you want to import from your local desktop file browser into a Qwaq Forums space.

**Supported File Types**

You can import the following types of files into a forum. For information about Microsoft Office products, see [http://office.microsoft.com/](http://office.microsoft.com/). For information about Open Office products, see [http://www.openoffice.org/](http://www.openoffice.org/). References to information about other proprietary file types are shown in the table.

<table>
<thead>
<tr>
<th>File Types</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Documents</td>
<td>Microsoft Word .DOC and RTF, Open Office ODT files</td>
</tr>
<tr>
<td>Spreadsheets</td>
<td>Microsoft Excel XLS and Open Office ODS files</td>
</tr>
<tr>
<td>Slides</td>
<td>Microsoft PowerPoint PPT and Open Office ODP files</td>
</tr>
<tr>
<td>Plain Text Files</td>
<td>TXT files produced with any of various text editors</td>
</tr>
<tr>
<td>Images</td>
<td>• JPG – Preferred for photographic images (images with broad color gradations)</td>
</tr>
<tr>
<td></td>
<td>• PNG – Good for most textures; PNG supports a full alpha channel.</td>
</tr>
<tr>
<td></td>
<td>• GIF – Best (fastest) choice for graphics images (text, line drawings, and so forth)</td>
</tr>
<tr>
<td></td>
<td>• BMP – Supported but not recommended, because the files are large and slow to transfer</td>
</tr>
<tr>
<td></td>
<td>(Please note that TIFF and TGA are not supported.)</td>
</tr>
<tr>
<td>3D Models</td>
<td>• Google SketchUp models exported as KMZ files for Google Earth 4 (<a href="http://sketchup.google.com/">http://sketchup.google.com/</a>) with .kmz extension</td>
</tr>
<tr>
<td></td>
<td>• VRML 97 (VRML2.0) files with .wrl extension. For more information on Virtual Reality Modeling Language technology and file formats, see <a href="http://www.w3.org/MarkUp/VRML/">http://www.w3.org/MarkUp/VRML/</a>.</td>
</tr>
<tr>
<td></td>
<td>• 3ds-Max ASE (ASCII Scene Export) files with .ase extension. (For specifics on export/import of these files see Guidelines for 3ds-Max ASE Files.)</td>
</tr>
</tbody>
</table>

For complete information on how to import and work with all supported model types in Qwaq Forums, see Working with 3D Models.
File Types | Description
--- | ---
Movies | MPEG-2 movies and associated audio

In general, the file to import should have the file type in lower case as an extension (for example a DOC file would be MyWordFile.doc).

See also, Linking to a Web Page.

Portals and Spaces

Generally speaking, **portals** provide views of 2D media (pictures, videos, and so forth) as well as connections or **gateways** between forums (virtual spaces). Forums can be linked to one another, and the portals provide a means of navigating between linked forums.

A forum can be modeled on constructs in the physical world for industries such as education, manufacturing, medicine, architecture, or any number of design efforts (and have some agreed-upon relationships to the physical world) but this is not required. Abstract concepts with no reference point in the physical world could also be modeled.

Although Qwaq Forums can be used to model real-world constructs, physical location is not a factor in the same way, so objects such as doors and spaces are not constrained to the same properties as in the physical world.

A portal is like a door that leads to another room. But unlike a physical door, a portal can connect any two spaces (even if one is hosted on a different computer on the other side of the world). Portals and spaces have additional properties to make the virtual landscape more accessible to you. For example, you can pick up a portal and carry it around with you so that the space it leads to is immediately accessible. You can re-position it as needed.

2D and 3D Portals

**2D portals** are 2D objects like wall panels. They can provide access to 2D objects such as Web pages, interactive maps, editable documents and whiteboards. Technically, a door is also a 2D portal that can provide access to 3D spaces via a forum **portal card**. The Sample Forum provides several examples of 2D portals to 2D media, like this slide presentation.
Qwaq Forums also provide doors or gates that are physical representations of portals to 3D spaces (other forums). You can link and travel to other forums in a number of ways using portals.

- Use the arrow above a door to jump to an existing portal entrance.
- Drag a link from the forums list onto a portal door to connect to it. Or, if the associated card tray has forum cards, you can drag a card onto the door to create a link to the forum on the card. Then move forward through the door (using keyboard, navigation bar, or mouse navigation) to enter into the forum. (See Moving Around in the Space for reminders on navigating.)
- Drag a forum link anywhere in the current forum to automatically create a portal door, then move through the resulting portal door to enter the forum.
- Notice that you can also enter a forum by simply linking to it (as described in Linking Forums). The purpose of using a door as the container for a forum link is that it provides a structural cue for link. Using these “physical” gateways for favorite forum links, you can customize your forum with suggested link paths for yourselves and other participants.
3D projections provide views of 3D objects and spaces (rooms, landscapes, other virtual worlds, and the objects they contain). Like portal doors, 3D projection cubes can also act as seamless entry points into the forums they contain. Pedestals are used to display 3D projections, so dragging a forum link onto a pedestal automatically renders the forum as a projection.

Click and drag the handles to rotate and view a projection from different angles, or navigate into it to enter its space (if “Allow Passage” option is enabled). For more details, see the topic below on 3D Projections.
Examples
All Qwaq Forums contain several examples of 2D portals to objects like maps, charts, text documents, and Web pages, and to 3D spaces (gateways for forum links).

When you drag a forum from the Forums list into the current space, a portal door (gateway) is created on one of the conference room walls. The name of the forum is added to the Places menu and is also posted above the portal to the room. (Choose Tools > Forums to get the Forums list.)

Once the portal is created, you can access this new room by navigating to it and moving through its new portal. The easiest way to find the new room is to select it from the Places menu. You can also take a spin around the room until you see the door to this new room (look for its name above a door, “Sample Forum”).

To return to the previous room, navigate back through its portal.

All portals have a portal card associated with them. Portal cards can be found on the card trays beside the portals. If you close a portal after going through it into a new space, the portal card provides an alternate means of getting back to the original space. You can drop the card on a panel or directly onto a wall to expose the portal and make the original room accessible again. Portal cards are provided for all existing objects and portal cards are created whenever new portals are added.

You can also drag a forum onto an existing portal door. Its portal card is added to its card tray.

Try this Sample Task of Creating a Portal Door to a Forum:
1. Choose the menu option Forums > All Forums to bring up the list of forums.
2. Drag and drop a forum name from the list onto any available wall space. (Dragging onto a wall creates a panel or door. Dragging onto the floor or open outdoor space creates a stand.)
3. At the prompt that asks whether you would like to set up a two-way link, click OK. Notice that a gateway (or door) to the new forum is created, and the name of the forum is added to the Places menu.
4. Click the arrow above the portal to center your avatar in front of it.
5. Move through the portal and into the new forum to explore it. (The portal must be open to enter it. If it is open, you can see through the door into the next room. Clicking the round knob to the right of the portal door opens/closes it. A portal to another forum is shown as a still image in gray until you log in to the forum. You cannot enter the other forum until you click on it and log in.)
6. Use the reset position control on the navigation panel to return to center of the primary room.

3D Projections
A 3D projection is a special kind of portal that gives a 360 degree live view or projection into a remote forum. The projection is rendered in a self-contained, navigable cube.

- To create a 3D projection, drag a link from the forums list onto a pedestal.
- Click the arrow above the projection to go to it.
- Use the portal handles to pan, zoom, and rotate the view. If there are participants in the projected site, you will see their avatars in the forum, along with any objects and artifacts.
- If the “Allow Passage” option is enabled on a projection, you can enter a forum by navigating your avatar into the cube, in much the same way you enter a forum through a portal door.
- Click the blue tab on the pedestal to get the 3D projection menu (includes options to “allow passage” into the projected forum, “show scroll box”, “delete link” to the forum, and so forth).
- Click the sphere on the pedestal to expand (show) or hide the projection cube. (Hiding cubes not in use improves performance and speed of the Qwaq Forums client.)

Here are details on how to manipulate a 3D projection using its handles.

<table>
<thead>
<tr>
<th>View</th>
<th>Keyboard and Mouse Actions to Get the View</th>
</tr>
</thead>
</table>
| Pan     | Left-mouse click and drag on any of the four corner handles to **pan** across the view of the space shown in the portal.  
This is equivalent to sweeping the lens of a camera across a space, incrementally bringing different slices of the landscape into view-finder. |
| Zoom    | Same actions as “Pan” with Shift key held down.  
Left-mouse click and drag on any of the four handles with the Shift key held down to zoom in and out on the view of the space represented in the portal. |
| Rotate  | Left-mouse click and drag the middle handles to rotate the 3D portal cube for a 360 degree view of the space shown in the portal. |

Here are details about the menu options on a 3D projection.
Reset Rotation – Returns cube to original position on pedestal.

Reset Viewpoint – Returns viewpoint (if changed by zoom or pan) to original viewpoint.

Copy Link to Inventory – Copies forum link contained in the cube to user inventory. (See Using an Inventory.)

Show Matte – Shows or hides the “matte” background on the cube. When the matte is hidden, the cube is transparent.

Show Scroll Box – Shows or hides cube handles.

Allow Passage – Enables or disables entry into the projected forum. When this is enabled, you can navigate into the cube to enter the forum it contains.

Disconnect Link – Removes the link to the currently projected forum.

Edit Label – Edit option on the 3D projection pedestal label.

Save Viewpoint for Reset – Saves the current viewpoint as the default “reset” option.

Delete Pedestal – Removes the pedestal.

You can start out in one forum, and from there navigate into another forum via a 3D projection.

Note that with projections (as with normal portals) your role and permissions will determine which forums you can access. Content developers can specify fine-grained permissions on projections, such as allowing 3D viewing of the cube from a remote forum but barring access into the forum from the cube.

Linking Forums

You can use a portal to create a structural link or entry point into another forum. Once forums are linked, all participants can move freely between them using the portal, a visible door in your forum. (If a linked forum has a different access level than the original forum, users must have appropriate login credentials to enter the linked forum.)

To continue with our “Web analogy”, this is the 3D version of designing a Web page and providing inline links to other Web sites for your users. In the 3D version, you are designing a “forum” instead of a Web page, and providing “portals” to other forums.

(Note that structural links are automatically created when you drag and drop a forum onto any surface. But you can also create a structural link first, before choosing a forum.)

To provide a structural link (a “door”) to another forum in your current forum:

1. Choose Forums > All Forums or Tools > Forums menu option to bring up the list of forums.
2. Drag and drop a forum name from the list onto any available wall space.

3. At the prompt that asks whether you would like to set up a two-way link, click **OK**. Notice that a gateway (or door) to the new forum is created, and the name of the forum is added to the Places menu.

4. Click the arrow above the portal to center your avatar in front of it.

5. Move through the portal and into the new forum to explore it. (The portal must be open to enter it. If it is open, you can see through the door into the next room. Clicking the round knob to the right of the portal door opens/closes it. A portal to another forum is shown as a still image in gray until you log in to the forum. You cannot enter the other forum until you click on it and log in.)

6. Use the reset position control on the navigation panel to return to center of the current room. Your original forum is now linked to this new forum. A portal card containing the address of the forum is added to the card tray next to the door.

   You can also add the portal card to your **inventory**. (See Using an Inventory.)

   A portal **gate** is automatically created for you when you drag the forum onto a space or wall.

### Deleting Links to Portals

Portal gates (and the structural links to forums that they contain) can be edited like any other 3D object via its edit box. (See Editing Objects for more detail on moving, rotating, or deleting 3D objects, including portal gates.)

You can delete a portal gate (and the structural forum link in a space) the same way you would any other 3D object:
7. Click the object edit button (_GRAPHIC_) on the toolbar (to get the edit object cursor), then click the portal gate/link you want to delete to bring up its edit box.

8. Click anywhere on the edit box to bring up the menu.

9. Click Delete, then click Yes to confirm the action.

(If you want to leave the portal gate structure in place, but disconnect the link to the forum, then choose Disconnect from this same menu instead.)

File Cards

File cards are provided as an efficient means of storing and accessing multiple forum links, web pages, and media. We sometimes refer to these cards based on the type of media they contain (for example, portal cards contain forum links, Web link cards contain URLs, and media cards contain pictures, movies, and so forth.) But file cards all work in basically the same manner; you can store them in card trays or rolodexes, you can mouse over them to read their labels, and you can drag them onto surfaces or into spaces to access their contents.

Try this Sample with Portal Cards

1. Navigate to a set of cards on one of the chat stations or podiums.

2. Hover and move the cursor slowly over the cards to pull up and view each one.

3. Now select a card and click and drag it onto any empty surface (like a wall) to expand and view the contents of it. The card expands into a 2D or 3D portal and gives you full access to the space it connects to.

4. These cards are also created for you when you add certain types of new objects. For example when you link to a forum (as described in Linking Forums), a portal card is placed by the new portal (door) as a marker. If you close the portal you can always use the card to expand it and make it accessible to you. You can carry the card around with you (or carry the whole door around) so that you have immediate access to a fully expanded view of the object or space it represents.
Manipulating Objects

Sample Forums include a variety of predefined, interactive 2D and 3D objects. These include the portals and 3D spaces and projections already discussed, along with some more readily familiar objects such as:

- Chat stations
- Maps, charts, and other 2D documents
- Web browsers
- Editable white boards and text documents
- Card stands, trays, and portal cards (for storing links to Web pages, documents, 3D portals, and so forth)
- Pedestals which provide a nice surface area for 3D projections, and many other objects

This section discusses how to manipulate and use these more “familiar” objects which, in Qwaq Forums, are enriched with some extraordinary properties and capabilities.

Manipulating 3D Objects

3D objects like chat station desks, tables, and card trays have the following points of control and associated behaviors. (Note that clicking on an object automatically puts you in Edit mode. Navigation and Edit modes are described in Moving Around in the Space.)

**Move a 3D Object Any Distance**

To move on the horizontal or “ground” plane (any distance across a room or landscape), hover the cursor over the lower plane of the object, then click and drag the bottom part of it.

**Rotate an Object**

To rotate or “spin” an object in place, hover the cursor over the top area of it, then click and drag it in any direction to set the spin in the direction of the drag. This gives you a view of the object from different perspectives, and lets you see all of its sides and surfaces.
Rotate a 3D Projection
A 3D projection is a special type of 3D portal object that represents a local view into a remote world. A 3D projection can be viewed from all angles by grabbing one of its handles and rotating it in any direction. It can also be set into a spin. For more information, see the previous topic on 3D Projections.

Grab and Carry an Object
To grab hold of an object and take it with you wherever you go, click on the sphere (orb) above it. The object will move to you (and thereby magnify in relationship to other objects in the room). When you move through the space, the object will “follow” you around the room, through portals, and into other rooms, landscapes, and worlds.

To drop or release the object, click its sphere again. It will be placed wherever you leave it. (In future demos and releases, you will have the option of leaving an object where you carried it or automatically returning it to its original location when you let go of it.)

Manipulating 2D Objects in Panels
2D objects (like Web browsers or text files) can be contained in panels.
At startup, panels containing some pre-defined 2D objects (like Web browsers, documents, maps, white boards) generally are displayed on the walls in a Forum. You can reposition these objects by moving them around, or even carry them with you to another location.

You can add new panels. When you bring up a Web page via the Actions > Add Web Link option or import a file (File > Import), drag and drop it onto a wall to create a panel.

Also, if you drag-and-drop a web page or media card on a wall, it automatically displays in a panel.

Panels have the following points of control and associated behaviors.

**Bring Panel to Main View**

Click the Viewpoint arrow to position your avatar directly in front of a panel. This brings the 2D object in the panel to full screen, which is a useful perspective from which to browse Web pages, read or edit a document, draw on a whiteboard, and so forth.

**Edit Mode and Navigation Mode**

Some Web pages, documents, and whiteboards Qwaq Forums are interactive and editable (writeable). The annotation tool also gives you a display for typing in content.

Qwaq Forums provide two modes with the following indicators and controls.

<table>
<thead>
<tr>
<th>Mode</th>
<th>Indicator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit</td>
<td>![Keyboard Icon]</td>
<td>Use this mode to edit 2D objects such as white boards, documents, address bars in Web browsers, annotations and so forth. Click on the editable object to switch into this mode (from Navigation mode). When you are in <strong>Edit mode</strong>, the “keyboard” icon is displayed in the lower left of the Qwaq Forums window, next to the Navigation panel (if that is currently displayed via mouse-over).</td>
</tr>
<tr>
<td>Navigation or Drive</td>
<td>![Keyboard Icon]</td>
<td>Use this mode to move avatar through the space and manipulate 2D and 3D objects. Click the keyboard, press the Escape key (Esc) on your keyboard, or click outside of an editable panel object to switch back into Navigation mode from Edit mode. If there is no Edit mode “keyboard” icon in the lower left of your Qwaq Forums window, you are in <strong>Navigation (Drive) mode</strong>. For more information on Navigation mode and controls, see Navigation Panel topic.</td>
</tr>
</tbody>
</table>

**Move a Panel in Any Direction**

To move a panel in any direction on the plane of the wall, **click and drag anywhere on the top bar of the frame**. (This will work if the panel is set to “Allow Moving”, which is the default for provided panels in template forums. See the table below on panel menu options, including the “Allow Moving” toggle.)

**Get Menu on Panel**

To get a menu of options on a panel, click the blue menu tab in the upper left. This provides options to hide/show the frame, privacy, and copy to inventory, toggles to allow/disallow moving, resizing, or turning, along with options to clear the panel of current content or delete the panel.
### Menu Options on a Panel

<table>
<thead>
<tr>
<th>Menu Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hide Frame</td>
<td>Toggle to hide or show the frame.</td>
</tr>
<tr>
<td></td>
<td>By default, frames are shown (“Hide Frame” is unchecked.)</td>
</tr>
<tr>
<td></td>
<td>Click <strong>Hide Frame</strong> to hide the frame so that only the panel content is displayed. In this mode “Hide Frame” is checked.</td>
</tr>
<tr>
<td></td>
<td>To return to “show frame” mode, click anywhere on the displayed page to activate the frame controls, then click on the tab in the upper left to get the menu, and click “Hide Frame” to toggle the options so that it is unchecked.</td>
</tr>
<tr>
<td>Open Private Copy</td>
<td>Opens the current Web page in a Web browser on your local desktop. (This option is available on Web pages.)</td>
</tr>
<tr>
<td>Save Local Copy</td>
<td>Opens a file browser to specify a path and file name where you can save a local copy of file. (This option is available on files.)</td>
</tr>
<tr>
<td>Copy to Inventory</td>
<td>Copies the currently displayed content to your inventory. (For a Web page, the URL or file path is stored in the inventory.)</td>
</tr>
<tr>
<td>Allow Moving</td>
<td>Toggles on/off the option to move the panel around by clicking-and-dragging on the top bar of the panel.</td>
</tr>
<tr>
<td></td>
<td>When this option is on (checked), users can reposition the panel on the wall.</td>
</tr>
<tr>
<td></td>
<td>When this option is off (unchecked) the panel cannot be moved.</td>
</tr>
<tr>
<td>Allow Resizing</td>
<td>Toggles on/off the option to resize the panel by clicking-and-dragging on any of the sides or corners other than the top bar.</td>
</tr>
<tr>
<td></td>
<td>When this option is on (checked), users can resize the panel.</td>
</tr>
</tbody>
</table>
### Menu Option Description

**Allow Turning**
- Toggles on/off the option to turn or rotate the panel by clicking-and-dragging on any of the sides or corners *other than* the top bar.
- Turn the panel by click-dragging either side right or left.
- When this option is on (checked), users can turn the panel.
- When this option is off (unchecked) the panel cannot be turned.

**Clear**
- Clears or “erases” the current content from the panel and gives you a blank panel.
- Previously viewed files are stored in the card holder to the right of the frame so that you can access them again (by dragging-and-dropping a card from the card holder onto the panel).

**Delete**
- Removes the panel and its associated card holder (with its history of previously viewed content).

### Using an Inventory

The *inventory* is a portable container for keeping files, pictures, documents, portal cards or Web page URLs, and objects. Any file displayed in a panel or object in a space can be copied to your inventory. The inventory is “portable” in the sense that it is always available to you (linked with your user name) regardless of which forum you are in. You can carry files, portals, and objects with you from one forum to another forum, and display them on panels in those new forums.

It is generally easier to view and work with the contents of the inventory if you have point of view set to first person (*Tools > Point of View*). For more about *point of view* options, see the topics on Setting Preferences, Starting Position and Avatars, and Menu Options and Panels Reference.

### Show or Hide the Inventory

To show/hide the inventory, click the toolbar inventory button ( ) on the lower right, next to the Qwaq logo. When it is toggled to “show” or open, the inventory will pop up in mid-air in front of you. Click the toolbar inventory button again to hide the inventory.

### Copy Files to Inventory

To copy the contents of a panel to your inventory, click the tab on the upper left of the panel to get the panel menu, and choose **Copy to Inventory**.

To copy an object to your inventory, show (open) the inventory, then click-and-drag the object into the inventory.

### View and Select Inventory Contents

To scroll through and select objects in the inventory, show (open) the inventory and move the cursor back and forth. Sliding the cursor over the inventory like this will display tag lines describing each file in the inventory. The tag line showing indicates the file in the inventory that is currently selected.

### Display/Share Inventory Files

To display (or share) a file or object from your inventory in the current space, scroll through the inventory and select the file or object you want, then click-and-drag it into the space or onto a wall, as appropriate.
Finding Objects

- Navigate through the spaces and look for them.
- Use the Places menu, which lists Qwaq-provided and custom places you create via the Actions > Name this Place option.
- Use the Inspector to survey the forum contents. Choose Tools > Inspector to show the object tree for the current forum, then navigate the tree to find a particular item (click nodes to expand and show sub-nodes). You can use the Inspector to delete objects, although this is not generally recommended. See also Tools > Inspector, under the Menu Options and Panels Reference.

Deleting Files and Objects

- Click the object edit button ( ) on the toolbar (to get the edit object cursor), then click the object you want to delete to bring up its edit box. Click anywhere on the edit box to bring up the menu. Click Delete, then click Yes to confirm the action. (For more information on working with 3D objects, see Editing Objects under Working with Content.)
- To clear or delete the contents of a panel, click the tab on the upper left of the panel to get the panel menu and choose Clear or Delete. (For more on working with 2D objects, see Manipulating 2D Objects in Panels.)
- For information on deleting sounds, see Deleting a Sound under Working with Sound Effects.

You can also delete “hard-to-catch” objects (like butterflies) via the Inspector. Choose Tools > Inspector to show the object tree for the current forum, then navigate the tree to find a particular object (click nodes to expand and show sub-nodes). Right-click the object you want to delete and select Destroy from the Inspector popup menu.

For example, if you just created a butterfly you can find it in the object tree under Objects. Most recently created items are placed at the end of the list.

This is an advanced tool, so please use your discretion as to whether you really need to use this option for deleting items. Use it for deleting things only as a last resort.

Working with Content

Spaces, objects, and associated behaviors created in Qwaq Forums are referred to as content.

Everything we have covered so far involves navigation, annotation, and object manipulation tasks of provided content within an existing forum.

The collaborative environment offered on the Qwaq Collaboration Platform extends beyond basic use of existing applications spaces by giving participants the ability to modify and develop applications while they are using them. The primary way of modifying an application space is to modify its content.

All participants with appropriate privileges can modify existing content, remove content, and add new content and associated behaviors.

This section provides a brief overview of how to create content in a forum.

Adding a Chat Station

To add a chat station, choose Objects > Furniture > Chat Station from the menus. This places a new chat station (desk) in the room. Your new chat station will include:

- a rolodex containing 2D portal cards
• some panels you can raise and lower by clicking on them

• move, rotate, and spin properties of a chat station

Try this Sample Task to Add a Chat Station:

1. Choose Objects > Furniture > Chat Station to create a new one.
2. Move the chat station desk where you want it in the room. (To move the furniture, click and drag near the bottom of its legs.)
3. At the desk, click a viewing panel to expand it.
4. Choose one of the cards from the rolodex and drag it onto a desk panel.

Adding Card Holders

To add a rolodex for holding portal cards, choose Objects > Furniture > Card Tray on Stand or Objects > Furniture > Card Tray from the menus. This places a new card holder in the room. You can use the card holder to store links to both 2D objects (like Web pages) and 3D objects (rooms and landscapes).

Linking to a Web Page

To link to a Web page choose Actions > Add Web Link from the menus. This places the Web page in the room as a new Web link card. To view the Web page, drag and drop its link card onto any panel or any empty space on a wall.

You can use the Web browser as you would normally to navigate to any URL, with the added benefit of 3D collaborative context.

Adjusting the Light

To adjust the lighting in the room, choose Objects > Lights > <LightOption>. The options include cool or warm bulbs, floodlights, and so on.

Choose Actions > Lights > <On/Off> to toggle the lighting on or off. Low or dim lighting can be useful for video presentations or Web browsing.

Choose Actions > Lights > Reset All Lighting to remove/undo all the effects that were added with “Objects” lights.
Editing Objects

Getting an Edit Box on a 3D Object

To display the edit box for an existing 3D object, click the object edit button ( ) on the toolbar (to get the edit object cursor), and then click the object you want to edit.

Using an Edit Box to Manipulate a 3D Object

- **To move the object up or down**, hover the cursor over any side of the box and get the crosshairs cursor. Then click and drag anywhere in the plane of the side you are manipulating.

  For example, if you click on the “front” side of the box from your current perspective, you can click and drag the object up, down, left and right in front of you but you cannot pull it closer to you or push it away from you with this handle.

- **To pull or push the object**, either drive your avatar around to the “side” of its edit box (relative to where you want to move it) or rotate the box slightly, then click and drag one of the other sides of the box in that plane.

- **To rotate the object**
  
  - **in the horizontal plane**: hover the cursor over one of the solid vertical sides of the box to get a horizontal wheel. Click and drag the wheel right or left.
  
  - **in the vertical plane**: hover the cursor over one of the solid horizontal sides of the box to get a vertical wheel. Click and drag the wheel up or down.

You can re-set the rotation via the Reset Rotation option on the edit box menu. See “Getting a Menu on an Edit Box” below.

Getting a Menu on an Edit Box

3D object edit boxes have a menu from which you can choose several actions. To bring up the menu on an object edit box once it is open, click anywhere on the box. Options are provided for copying or deleting an object, and also for resetting the rotation settings of the object back to its starting position. When you are finished editing, click **Done** to close the edit box.

Deleting a 3D Object

Click the object edit button ( ) on the toolbar (to get the edit object cursor), then click the object you want to delete to bring up its edit box. Click anywhere on the edit box to bring up the menu. Click **Delete**, then click **Yes** to confirm the action. (This method works for deleting portal gates...
also, since they are 3D objects. See Linking Forums for more about portal gates.)

**Editing Object Textures and Colors**

Choose the Edit Material option from the object edit box menu to get a standard OpenGL style editor. You can use this menu to edit colors and textures on the selected object for which the edit box is visible. The changes you make to the object are mirrored on the example teapot object in the Edit Materials box.

You can also bring up the materials editor by clicking on its toolbar button and then selecting a surface in the forum to which you want to add a texture or color.

The materials editor is particularly useful for adding colors and textures to 3D models. For information on 3D modeling, see Working with 3D Models.

**Working with Sound Effects**

You can add sound effects to your Qwaq Forums. Sounds are treated similarly to other objects. You can add sounds, place them in the space, move them around, and remove them.

**Adding a Sound**

To add a sound, choose Objects > Sound Effects > <Sound of Your Choice>.

**Placing a Sound in the Space**

When you first add a sound, you get a green Edit Box around it. You can use the edit box to move the sound around in the space and place it where you want it, just like any other object. For more information, see Editing Objects.

**Deleting a Sound**

To delete a sound object, bring up its edit box menu, click Delete, and follow the options to confirm the delete.

**Working with 3D Models**

You can import models into Qwaq Forums (see Importing Your Content), and then manipulate
them using the positioning and coloring tools (materials editor) (see in Editing Objects).

The tools provided in Qwaq Forums are not meant to replace 3D-modeling tools. Rather, you can think of Forums as a page composing or web-publishing tool for combining models and making them available to a community.

Please keep in mind that Qwaq Forums is a real-time environment, not an offline rendering system. Models that are optimized for simplicity rather than photorealism will be more effective. We suggest opting for simple models over complex ones to maximize system performance and enhance user experience in your forums.

Supported File Types

Supported file types for 3D models are:

- Google SketchUp models exported as KMZ files for Google Earth 4 (http://sketchup.google.com/) with .kmz extension
- VRML 97 (VRML2.0) files with .wrl extension.
  For more information on Virtual Reality Modeling Language technology and file formats, see http://www.w3.org/MarkUp/VRML/.
- 3ds-Max ASE (ASCII Scene Export) files with .ase extension.

Supported file types for images are:

- JPG – Preferred for photographic images (images with broad color gradations)
- PNG – Good for most textures; PNG supports a full alpha channel.
- GIF – Best (fastest) choice for graphics images (text, line drawings, and so forth)
- BMP – Supported but not recommended, because the files are large and slow to transfer
  (Please note that TIFF and TGA are not supported.)

Guidelines for Importing Models

General steps for importing all types of supported content are described in Importing Your Content.

To import a 3D model choose File > Import or simply drag-and-drop the file into a forum.

Here are some guidelines specific to importing 3D models:

- The source file should reside in a directory that also contains the required texture files.
  (Except for Google SketchUp KMZ: files; this format is an archive with textures.)
- The import process will report missing textures. Locate the textures, copy them into the folder with the model source file, and import again.
- The imported model appears in a green 3-D manipulation edit box. Use this to position and size the model. The edit box offers a menu when you left-click it with the mouse; one option is 'Done' which you can use to hide the edit box.
- Absolute scales are not honored when models are imported. Instead, models are rescaled to fit the available region in front of the avatar with some heuristics limiting size. (This is done because most models are imported into forums for review or show-and-tell, inside the forum collaboration environment.)
When importing large models, such as rooms or buildings or landscapes, start in a Staging Area, Campus, or Gallery rather than a smaller forum. The Staging Area has no walls, and offers large boundaries so there is room to scale and organize a large model.

Guidelines for 3ds-Max ASE Files

If you are working with 3ds-Max ASE files, follow these instructions to export the models in a format that can be imported into Qwaq Forums.

On the dialog displayed after you choose Export for an .ase file, select **ASCII Scene Export**, and enter a file name.

Specify settings as follows for the ASCII export. Note that these choices do not affect your original model; only the exported ASCII file.

**Output Options**
- **Mesh Definition** - Always select this.
- **Materials** - Always select this.

**Animation and Joints**
- **Transform Animation Keys**
- **Animated Mesh**
- **Animated Camera/Light Settings**
- **Inverse Kinematic Joints**

These should all be deselected. Qwaq Forums does not import 3ds animation.

**Mesh Options**
- **Mesh Normals** – These may be omitted in many cases, to save file space. Experiment; you may need to include Normals to preserve special smoothing details in your model.
- **Mapping Coordinates** – If your model uses mapped textures, select this option. Otherwise deselect it. (3ds-Max generates a great deal of mapping data even for meshes that do not use any maps.)
- **Vertex Colors** – These can often be omitted. If you use color gradient materials in 3ds max, select this option; otherwise, deselect it.
Object Types
- Geometric – Always select this.
- Shapes – Cameras, Lights - Deselect these.
- Helpers – Select this only if your model uses named 3ds-Max Groups to define a hierarchy that you will be manipulating in software. Usually off. Helpers can make the export file large.

Controller Output
These animation controls are ignored.

Precision
Reduce this to 2 digits, or 3 digits if your models are both small and detailed. (Fewer digits makes the export much smaller and faster to load.)

3D Modeling Guidelines
Following are guidelines on a variety of aspects related to 3D modeling in Qwaq Forums.

Rendering Engine
The rendering engine is Open Croquet. This is an OpenGL-based real-time environment, rather like a game engine.

Performance
For performance, low polygon models are preferred. This is real-time environment; models designed for offline rendering will slow the frame rate. Currently, procedural shaders are not supported.

Textures
- Qwaq Forums supports normal (diffuse) texture maps and opacity maps.
- No environment maps are supported.
- Textures may be in .PNG, .GIF, .JPG, or .BMP formats; not Targa or TIFF. Choose the best compression scheme for each texture. File size, as well as image resolution, affects load time.
- Image size should be as small as possible. For surface patterns, 32x32 or 128x128, for instance.
- Textures larger than 512x512 should be used rarely - they may be needed for ground or sky features where a very large single surface is needed, but are best avoided.

Materials
- Materials can be used freely.
- As a guideline, specify colors so that diffuse is the full-strength color (1,1,0 for very bright yellow), while ambient is 1/2 that intensity.
- Features related to mirrors and light reflection are often not as pleasing in OpenGL as in offline-rendering tools.

Scaling and Coordinates
- The origin (0,0,0) should be the vertical bottom and horizontal center of most freestanding objects. If a table is modeled, its 0,0 would be at the center between the bottom ends of the legs.
• In the forum models, 1.0 units = 1 foot. (There is no need for great precision, but this scale should apply across all models.)

• A typical avatar is about 5.5 feet tall.

• The conference room is about 60 by 80 feet; offices about half that, and campus areas are 600 feet to the boundaries.

**Lighting**

• Lighting is set up globally. Imports need not include lights; they will be ignored.

• Assume relatively “normal” lighting; we use a simple “stage” lighting setup with slight variations in color from different directions, so there is some shape emphasis derived from the light (it is otherwise quite flat). The lighting enters the scene from all sides, at a bit above a 45 degree angle to the horizon.

**Example: Designing a Library Forum**

For content developers and teams with advanced goals of designing and developing custom forums, the following use case provides suggestions for how you might want to approach a new project.

Keep in mind that each project will be different depending on a variety of factors, including:

• Background of forum developers, and areas of expertise or research (What do I already know and what do I need to learn in order to develop a forum?)

• Goals for the new forum (What is the forum for?)

• Target participants for the new forum (Who will use the forum?)

The following design and development guidelines are contributed by the two-person team who developed the first Qwaq Forums “Library” through trial-and-error with some help from the Qwaq development group. The resulting Library forum is now provided in modified form as the Qwaq Forums “Library template”. You might find it useful to use this approach as a checklist for jump-starting your first projects.

**Identify Goals and Nature of the Forum**

• What is the use the purpose of the forum?

• Will there be many meetings? How often?

• How many will attend?

• Will there be simultaneous meetings in the forum?

• Who will use the forum? (Describe participant users.)

• How many people will be using each space at a time?

For example, we discovered that our forum would be a library where users will be: archiving files, browsing casually, searching deliberately, working privately in a public space (synchronously or asynchronously), working collaboratively in a public area and in semi-private conference areas where privacy could be modulated by proximity and sound cues. Users would have meetings that are non-library related, using it as a public space, and so forth.
Visualize Physical Elements and Feel of the Space

- Based on the purpose of the forum, begin to determine the physical nature of the forum.
  For the library, we determined that we would need one large common space where synchronous and asynchronous browsing and open meetings could occur. We also defined the need for 3 or 4 semi-private spaces within the forum for special-interest meetings. We determined that there might be as many as 10 or 15 people at time in the common space and 3-to-5 in the semiprivate rooms. We also defined a public patio area to accommodate casual break-out meetings in a pastoral, more relaxed atmosphere.

- Decide on an architectural style that supports scope, purpose, and goals of the forum.
  Once we decided on the number and purpose of the rooms in the forum, we agreed on an architectural style—modern and airy with natural materials. We found sample library interior photos through Web search and placed them in a blank (Stage) forum.

- Identify an existing forum template that most closely fits footprint required for your new forum. Use this as a starting point to more clearly define the needs and style of the space you are going to build.
  We started with a forum template that seemed to have an appropriate footprint. We had in-forum meetings with the Qwaq team (the “client for whom we were developing the library) to consider various styles of buildings, color themes, structural elements and configurations, interior design and furnishings, and agreed on directions for these variables. By moving around in the space together, we agreed that the space would be three times bigger than the forum template we had selected. We learned that Avatars need at least twice as much space to comfortably navigate around in versus people in real-world spaces.

- Draft floor plans and layouts.
  We did pencil sketches of several floor plans, including furniture layouts, that we thought might work and put scans of those drawings up in the (now larger) Stage forum, and met synchronously with the client. We agreed on a floor plan, which turned out to be a combination of two of the drawings. We also took that opportunity to review sample 3D furniture and decorations in the space. When all feedback had been aggregated and agreed upon, we moved into construction.
Construction, Materials, and Tools

We applied our floor plan literally by building the floor first, with a Qfloor. Then we erected interior and exterior wall structures using Qwalls.

We then adjusted the materials and transparencies of the Qwalls using the Qwaq materials editor. Because we wanted a realistic look for our forum, materials for the walls were rendered in Adobe Photoshop with texture and lighting effects “baked in”, saved as low-medium resolution .jpgs, dragged into the editing carousel, and then applied as textures to the Qwalls.

If realism was not as important, we could have used the stock textures found in the Qwaq materials editor. Because we wanted exclusive ownership of furniture and accessories for the forum, we built those elements from scratch in Google SketchUp. Texture maps used on objects were also rendered in Photoshop, saved as .jpgs, added to the SketchUp materials swatch library, applied to the objects in SketchUp, and then imported as .kmz files into our forum and positioned.

Our beamed ceiling was created the same way. If exclusivity was not an issue, we could have drawn upon a large library of objects in the Google SketchUp library for use in our forum. Using SketchUp objects with a minimum number of polygons and the lowest possible file size for texture maps maximizes speed in the forum environment. We experimented quite a bit to determine the polygon/resolution balance that would maximize performance while maintaining the realistic feel we were looking for.

We had some special needs that were fulfilled by Qwaq technical support. We created, in Photoshop, translucent glass panels that sat in an opaque mullion for our front entrance. We saved this layer file as a .png and mapped it to our Qwall. Qwaq enabled the transparency so that the mullion remained opaque while we could see through the translucent glass to our patio. Qwaq also enabled more realistic sound presence for our semi-private rooms and patio area, and inserted the moving cloud sky outside. Qwaq also made our ceiling (created in Google SketchUp) transparent when viewed in plan or Bird’s eye mode.
Tips and Tricks During Construction

- Because we had an exterior area in our forum, we spent time constructing that space, including walls, furniture and integrating exterior oddities that arose from the interior construction, such as overlapping or over extended interior objects. We used plants from the Qwaq library. We learned that we could achieve a realistic outdoor environment by enlarging Qwaq trees substantially, without sacrificing performance.

- During construction, no Qwaq lights were added. Using the default lighting assured that our colors and mapped textures would read consistently.

- We “ignored gravity” (Extras > Ignore Gravity) during most of the construction process to facilitate placement of construction elements.

- Size adjustments of Qwalls are most stable when made by clicking on the blue control box in the bottom corner of each wall vs. using the object editing tools.

- We learned that strategic placement of Qwaq mirrors near the point of entry that we had set could help new visitors get oriented.

- We used the Inspector tool to help find objects and textures throughout the process.

- We used the Performance tool to check polygon use in the forum, as we added in objects.

- We turned off AutoSave in preferences so that we could determine when it was time to save.

- We met in the forum throughout this process synchronously and asynchronously to review progress, while still allowing the artist time and space to experiment without interruptions.

- After signoff on above, several hours were spent making final fit and finish adjustments, and limits of motion adjustments.

Troubleshooting

- If choosing Help > User Guide results in security-related messages about pop-ups or scripts, please refer to the topic Web Browser Popup Blockers and Security Warnings for information on how to set your Web browser to allow dynamic content from www.qwaq.com.
• Various tools are provided in the "Extras" menu to help with troubleshooting sound problems. See the section in this guide on Communicating with Voice and Text Chat (which includes a subtopic on In-Forum Sound Check) for a full discussion microphone, speaker, and sound setup.

• Choose Extras > Clear Resource Cache if you are having trouble with textures or imported models. This tool helps diagnose and recover from certain problems with corrupted textures and imported models. When you run this command, quit Qwaq Forums and return, resources will be fetched fresh from the server upon login.

• Choose Tools > Network Activity to get a live monitor showing bandwidth usage of your own client (when it’s sending data over the network to the server) and that of others (when they are sending data to you via the server).

On the Network Activity monitor, different types of network activity are measured, such as replication, simulation, audio, video, and so forth. The categories are color-coded on “In” and “Out” graphs.

The “In” graph shows data being sent to your client via the server. For example, if you are in a forum with other participants and one or more are adding and manipulating in-forum media, the “In” data will tend to spike.

The “Out” graph shows the amount of data your client is sending. For example, if you are adding or manipulating in-forum media, the “Out” data will tend to spike.

Network activity is shown by default in “60-Second Peak” time frame. To change the monitoring time frame, click the “60-Second Peak” text at the top of the dialog to cycle through other time-frame choices. Other choices include 5-Minute Max, 60-Minute Max, 5-Second Peak, and 15-Second Peak.

• Choose Tools > Performance, to get current performance statistics on your client including network simulation, queued inbound and outbound message tally, object count, network latency, and so forth.
Menu Options and Panels Reference

The following docked panels are available in all Forums.

### People
- **<Users in Current Forum>**
  - Lists other users in the current forum. If no others are present in the forum, the menu indicates that there are “No Other Users Here”.
  - The forum administrator can right-click on the user list to get a “Manage Users…” option to display the user management dialog for the local forum. (“Manage Users…” is also available in the Extras menu.)
  - Related topics: Listing Users at Login, Finding and Navigating to Other Users, and Managing Forum Users (Forum Administrator Task)

### Places
- Lists named places
  - Lists standard and custom named places. Standard named places include:
    - Home – Entry point or center of forum
    - Bird’s Eye - Provides a high level overview of the space from the viewpoint of high above, looking down from a faraway angle.
    - Plan View - Provides a stylized overview of the space from directly above the room. This view gives you a realistic looking “blueprint” view; a good way to see the structure of the space and all objects contained in it.
    - Return to the center (default starting point) of the current application space.
  - You can create a custom named place with the Actions > Name this Place menu option. Choosing this option brings up a dialog where you can name and save your current location. When you name a place, your new placemark shows up in the Places menu and you can choose it and link to it the same way you can link to the pre-defined placemarks in this menu.

### Menu Options

The following table summarizes actions and options available on the Qwaq Forums menus.

<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Import</td>
<td>Related topic: Importing Your Content Import a file. Brings up a file browser where you can select the file you want to import. You can import the following Microsoft Office (<a href="http://office.microsoft.com/en-us/default.aspx">http://office.microsoft.com/en-us/default.aspx</a>) file types and the Open Office (<a href="http://www.openoffice.org/">http://www.openoffice.org/</a>) equivalents, respectively: • Documents (DOC and RTF files, Open Office ODT files) • Spreadsheets (Microsoft Excel XLS, Open Office ODS) • Slides (Microsoft PowerPoint PPT and Open Office ODP) You can also import: • Plain text files (TXT) • Image files (including GIF, JEPG, PNG) • Adobe Acrobat PDF files (<a href="http://www.adobe.com/products/acrobat/">http://www.adobe.com/products/acrobat/</a>) • Google SketchUp models (exported as KMZ files with Google Earth 4; please see <a href="http://sketchup.google.com/">http://sketchup.google.com/</a>) • MPEG-2 movies and associated audio The file to import should have the file type in lower case as an</td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>----------</td>
<td>----------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Save</td>
<td>Changes to the current forum.</td>
</tr>
<tr>
<td></td>
<td>Save Copy As</td>
<td>Saves a copy of the current forum.</td>
</tr>
<tr>
<td></td>
<td>Save As Template</td>
<td>Saves a copy of the current forum as a published template.</td>
</tr>
<tr>
<td></td>
<td>Save All</td>
<td>Saves changes to the current forum, and all other forums you added or modified in this session.</td>
</tr>
<tr>
<td></td>
<td>Log Out</td>
<td>Disconnect and close the current application space (world).</td>
</tr>
<tr>
<td></td>
<td>Exit</td>
<td>Disconnect from the current application space and exit Qwaq Forums.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Tools</strong></td>
</tr>
<tr>
<td></td>
<td>Point of View</td>
<td>• First Person - Your avatar is not in the view with the exception of the initial zoom-in queue. This is a “hands-on” mode you typically use to do work.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Near - Your avatar is visible in a close-up view (head only), as if you are standing immediately behind it.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Far – Your avatar is visible as if you are standing behind it (head and upper body).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Normal – You have a broad view of your avatar in the space; your own avatar is displayed similarly to other avatars in proximity. This is the point of view you might expect in an online game.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Text Chat</strong>                                                                                Displays the Text Chat window. (See Text Chat.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Forums</strong>                                                                                                                                Provides a list of available forums to which you can connect from within your current forum.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Drag and drop a forum from the list onto any available area in the current space. A gateway portal to the forum is created.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Related topics: Starting the Browser and Joining a Forum, Portals and Spaces</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>History</strong>                                                                                  Hides or shows your History list of visited forums (similar to a history of visited Web sites in a browser).</td>
</tr>
<tr>
<td></td>
<td></td>
<td>To return to a previously visited forum, open the History list, right-click on a forum in the list, and choose Go.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can also use back/next buttons to toggle through the forum locations in your History. See Go Back/Next to Previously Visited Forums.</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Inspector</strong>                                                                                 Provides a tree view of the back-end code for a forum similar in nature to the page source view of HTML code for a Web page in a browser.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>The Inspector shows the hierarchy of classes and objects that make up the forum. Objects with icons next to them have child objects that inherit properties from their parents. You can click the icon next to a parent object to display its children. Click again to close the expanded view. (See also Finding Objects.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>You can use the Inspector to delete items that are not easy to find in the visible space, such as sounds. (See Deleting Files and Objects.)</td>
</tr>
<tr>
<td></td>
<td></td>
<td><strong>Network Activity</strong>                                                                          Shows statistics on network activity in the current forums.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Related topic: Troubleshooting</td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>--------------</td>
<td>--------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>Performance</strong></td>
<td>Shows current performance indicators related to your client including network simulation, queued inbound and outbound message tally, object count, network latency, and so forth.</td>
<td>Related topic: Troubleshooting</td>
</tr>
<tr>
<td><strong>Scripts</strong></td>
<td>Provides ready-made scripts for animated behaviors. You can code behavior into an object by associating one of these scripts with it.</td>
<td></td>
</tr>
<tr>
<td><strong>Transcript</strong></td>
<td>Hides or shows a system messages log, useful for the purposes of monitoring system calls to objects and for debugging.</td>
<td></td>
</tr>
<tr>
<td><strong>Stereo</strong></td>
<td>• Off</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Hardware</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Anaglyph</td>
<td></td>
</tr>
<tr>
<td><strong>My Avatar</strong></td>
<td>Brings up an Avatar preferences dialog where you can choose a picture and a badge, and change shape and color of your avatar.</td>
<td>Related topics: Setting Preferences, Starting Position and Avatars, Wearing a Badge</td>
</tr>
<tr>
<td><strong>Preferences</strong></td>
<td>Brings up a Preferences dialog where you can choose:</td>
<td>Related topics: Setting Preferences, Starting Position and Avatars, Wearing a Badge</td>
</tr>
<tr>
<td></td>
<td>• screen name, picture, and colors for your avatar</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• point of view (first person, near, normal, or far)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• provide profile details</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• set viewing and sound preferences per your user login</td>
<td></td>
</tr>
<tr>
<td><strong>Sound</strong></td>
<td>Related topic: Audio Conferencing and Sound</td>
<td>Brings up Sound Levels dialog, which provides options for adjusting Volume, Input Level, and Noise filter from within Qwaq Forums. These options let you adjust the low-level sound cutoff filter to suit your audio equipment. Also includes toggle for “Push-to-Talk” option and “Hear Myself”.</td>
</tr>
<tr>
<td></td>
<td>• Volume – Adjusts the speaker volume (output) for your computer.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Input Level – Adjusts the microphone volume (input) for your computer.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Noise Filter – Adjusts the volume filter to reduce hiss as needed for your computer and audio equipment.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Use Push-to-Talk – Causes your Qwaq Forums microphone to be live (active) only while the keyboard Ctrl key is depressed. You can turn this option “on” or “off” in the Sound Levels dialog or from the toolbar by right-clicking microphone icon until microphone popup menu is displayed.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>• Hear Myself (a feedback testing feature) and Reset Sound settings are available here, as well. (See descriptions of these options in the “Extras” menu detail.)</td>
<td></td>
</tr>
<tr>
<td><strong>Bookmark</strong></td>
<td>Bookmark this Place</td>
<td>Creates a link to your current location.</td>
</tr>
<tr>
<td></td>
<td>Organize Bookmarks</td>
<td></td>
</tr>
<tr>
<td><strong>Actions</strong></td>
<td>Add Web Link</td>
<td>Creates a link to the specified URL (Web page) as a link card. You can drag the link card onto any panel or surface to view the Web page. If you drag it onto a plain surface, a panel is created for you.</td>
</tr>
<tr>
<td></td>
<td>Hide/Show</td>
<td>Toggle to hide or show editing tools and annotations, painting markups,</td>
</tr>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td>------</td>
<td>-------------------------</td>
<td>--------------------------------------------------------------------------------</td>
</tr>
<tr>
<td></td>
<td>Markups</td>
<td>post-its, and so on.</td>
</tr>
<tr>
<td></td>
<td>Lights On/Off</td>
<td>Dims or brightens the lighting in the Space. Low (dim) lighting can be useful for video presentations or Web browsing.</td>
</tr>
<tr>
<td></td>
<td>Reset Lighting</td>
<td>Sets lighting back to default setting for the forum (normal lighting).</td>
</tr>
<tr>
<td></td>
<td>Increase/Decrease</td>
<td>Select this toggle to raise or lower the ceiling on the current forum.</td>
</tr>
<tr>
<td></td>
<td>Room Height</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Objects</td>
<td>Provides ability to create new instances of objects in a given space. The objects available will vary depending on which space you are in. For example, you can add new card stands, card trays, chat stations (desks), pedestals, and text documents, change the lighting style, and so forth.</td>
</tr>
<tr>
<td></td>
<td>Display</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Card Holders</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Desktop Display</td>
<td>– Adds a desktop-sized display panel</td>
</tr>
<tr>
<td></td>
<td>Display Panel</td>
<td>– Adds a display panel in which you can add Web URLs, pictures, videos, and so forth. Display panels are more appropriate to hang on walls, whereas display stands can be placed in the center of a room.</td>
</tr>
<tr>
<td></td>
<td>Display Stand</td>
<td>– Adds a stand.</td>
</tr>
<tr>
<td></td>
<td>Mirror</td>
<td>– Adds a mirror.</td>
</tr>
<tr>
<td></td>
<td>Poster</td>
<td>– Provides a blank poster for displaying images (typically on a wall). Drop an image card onto the poster to display the image.</td>
</tr>
<tr>
<td></td>
<td>Sign</td>
<td>– Provides an editable sign.</td>
</tr>
<tr>
<td></td>
<td>Scribble</td>
<td>– Adds a scribble pad that you can drop/place in the forum.</td>
</tr>
<tr>
<td></td>
<td>Text Document</td>
<td>– Adds a plain text document on a wall panel.</td>
</tr>
<tr>
<td></td>
<td>Timer</td>
<td>– Provides a shared clock that you can use to help organize group activity.</td>
</tr>
<tr>
<td></td>
<td>Garden</td>
<td>Adds selected animals and plants to the space. For example, you might want to add these outdoors on a campus.</td>
</tr>
<tr>
<td></td>
<td>Sample</td>
<td>Adds special, sample objects.</td>
</tr>
<tr>
<td></td>
<td>Lights</td>
<td>Provides various lighting styles. Selecting one of these options changes the lighting style in the current space.</td>
</tr>
</tbody>
</table>
To dim or brighten the lights, regardless of the lighting style, choose Actions > Lights On/Off.

To reset all lighting to default (undo the “Objects” menu settings), choose Actions > Lights > Reset All Lighting.

Shapes
Adds the selected shape (cone, cube, cylinder, disk, and so forth).

Sound Effects
Provides various sound effects that you can add to the space as objects. Sound effects can be moved around, edited, and deleted as needed.

See Working with Sound Effects for more information.

Extras

Ignore Gravity (Fly)
Removes normal physical constraints for your avatar in the forums. You can walk through walls, and if you raise yourself by clicking Page up key, you will float instead of falling back to the ground. Use Page Up and Page Down to control your altitude. (On Macs, use Function key in combination with Page Up and Page Down.)

Use the C and R keys to change viewing angle (look up and down, respectively). Right-mouse drive mode resets viewing angle to horizontal, while keyboard drive maintains the up/down angle of view.

Set Limits of Motion…
Forum walls are configurable, virtual boundaries. An avatar doesn’t actually collide with walls, but rather hits against an invisible rectangle (this is why you walk right through walls in a “Gallery” forum).

The “Set Limits of Motion” option brings up a dialog where you can manually set the size of this virtual, bounding area.

Set Entry Position Here
Sets the current position of your avatar in the forum as the entry point (home) for new arrivals (you and other participants) in the current forum.

Hear Myself
Sound check utility for voice chat. Toggle this option on to hear yourself as others hear you. Normally, your own voice is not played back in your client. By default, this option is off.

Reset Sound
Troubleshooting option for resolving sound problems. Choose this option to reset the sound link between your Qwaq Forums client and operating system.

Test Built-In Sound
Sound check utility for in-forum audio that verifies whether the Qwaq Forums built-in sounds are working in your client. Toggle this option on to play a forums-generated test sound repeatedly. If you hear a sound when you choose this option, the built-in sound is working. Toggle off to stop the sound.

Test Spatialized Sound
Sound check utility for in-forum audio that verifies whether the spatialized sounds are working in your client. Toggle this option on to play a forums-generated, spatialized test sound repeatedly. If you hear a sound when you choose this option, the built-in, spatialized sounds are working properly. Toggle off to stop the sound.

Qwaq Forums uses OpenAL for spatialized sounds. OpenAL is a software prerequisite for Qwaq Forums. For more information, see System Requirements.

Test Voice Transport
Sound check utility for debugging microphone problems, this tests everything used by “Hear Myself”, except the microphone. Select this option to play a prerecorded voice saying "Testing voice chat" that everyone will hear as if you spoke it. (You will not hear it unless you have “Hear Myself” turned on.) If others hear the test message but do not hear you when you speak, something is probably wrong with your microphone.

Test QMS Launch
Qwaq Multi-Share (QMS) is the framework used for embedding
<table>
<thead>
<tr>
<th>Menu</th>
<th>Option</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Menu</td>
<td>Option</td>
<td>Description</td>
</tr>
<tr>
<td></td>
<td>Test 360 Rendering</td>
<td>Spins around for a pre-determined time period, and measures the average rendering rate over that period. Use this option to get a rough measure of performance.</td>
</tr>
<tr>
<td></td>
<td>Run Benchmark Suite</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Advanced Special Effects</td>
<td>Renders the gray snapshots of unloaded forums wavy and ethereal.</td>
</tr>
<tr>
<td></td>
<td>Report Quality of Service</td>
<td>Returns network measurements that are used to help improve Qwaq Forums performance. When this option is toggled on (indicated by a checkmark next to the menu option), your client sends a small update to the forums server every 2 minutes. No privacy-sensitive information is sent.</td>
</tr>
<tr>
<td></td>
<td>Clear Resource Cache</td>
<td>Helps diagnose and recover from certain problems with corrupted textures and imported models. When you run this command, quit Qwaq Forums and return, resources will be fetched fresh from the server upon login.</td>
</tr>
<tr>
<td></td>
<td>Manage Users…</td>
<td>Brings up the user management dialog for use by Qwaq Forums administrators.</td>
</tr>
<tr>
<td></td>
<td>Change My Password</td>
<td>Brings up a “change password” dialog. Forum users can change their own passwords as needed. Forum Administrators can also manage user names and passwords for from the User Management dialog. (See Managing Forum Users.)</td>
</tr>
<tr>
<td></td>
<td>Help</td>
<td>Links to this User Guide in HTML. Quick Help cards for common tasks are also provided via this menu, along with “About” copyright info. Related topic: Online Help</td>
</tr>
<tr>
<td></td>
<td>Quick Card Topics</td>
<td>Quick tips for getting up-to-speed on the basics like navigation with mouse or keyboard, importing content, and so forth.</td>
</tr>
</tbody>
</table>
Index

2D and 3D portals 43  voice 30
2D objects clearing
   manipulate 52  panels 53
   move See panel creating new forums 18
   read or write to Croquet
3D objects defined 6
   grab 52  dashboard 25
   manipulate deleting
   move 51  2D panels 53
   rotate 51  3D objects 58
3D projections 46  files and objects 56
   rotate 52  portal links 49
ActiveX controls DOC 42
   security warnings on Help read or write to 53
administrators Documentation 15
   forums edit
Adobe Acrobat edit material
   importing PDF files 2D objects 53
Apple Mac object editor 59
   as a supported platform
ASE 42, 60 examples
   exporting 61  3D portals and spaces 46
audio conferencing 30  adding and working with chat stations 56
avatar library forum 63
   away/present status portal cards 50
   choosing color files
   choosing picture importing 41
   gestures finding
   starting position objects 56
away users 29
status on avatar forums
back administrators 19
   history button back or next 29
badge campus 8
BMP conference room 8
card holders creating new 18
   add new gallery 8
   library 63
chat
   station logging in 11
   text logging out 22
   text, private office 8

www.qwaq.com
Forums v. 1.1.77
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>OpenAL</td>
<td>10</td>
</tr>
<tr>
<td>OpenGL</td>
<td>10</td>
</tr>
<tr>
<td>operating systems supported</td>
<td>10</td>
</tr>
<tr>
<td>panel</td>
<td>10</td>
</tr>
<tr>
<td>center view at</td>
<td>53</td>
</tr>
<tr>
<td>clearing content from</td>
<td>53</td>
</tr>
<tr>
<td>deleting</td>
<td>53</td>
</tr>
<tr>
<td>get menu on</td>
<td>53</td>
</tr>
<tr>
<td>manipulate 2D objects in</td>
<td>52</td>
</tr>
<tr>
<td>menu options</td>
<td>54</td>
</tr>
<tr>
<td>move</td>
<td>53</td>
</tr>
<tr>
<td>PDF</td>
<td>42</td>
</tr>
<tr>
<td>PNG</td>
<td>42, 60</td>
</tr>
<tr>
<td>point of view</td>
<td>17</td>
</tr>
<tr>
<td>popup blockers</td>
<td>16</td>
</tr>
<tr>
<td>PPT</td>
<td>42</td>
</tr>
<tr>
<td>presence</td>
<td>41</td>
</tr>
<tr>
<td>present</td>
<td>42</td>
</tr>
<tr>
<td>status status on avatar</td>
<td>30</td>
</tr>
<tr>
<td>print</td>
<td>15</td>
</tr>
<tr>
<td>Help topics</td>
<td>15</td>
</tr>
<tr>
<td>private</td>
<td>17</td>
</tr>
<tr>
<td>text chat</td>
<td>30</td>
</tr>
<tr>
<td>product intro</td>
<td>15</td>
</tr>
<tr>
<td>profile settings</td>
<td>17</td>
</tr>
<tr>
<td>proxy configuration</td>
<td>12, 14</td>
</tr>
<tr>
<td>push-to-talk</td>
<td>37</td>
</tr>
<tr>
<td>microphone</td>
<td>37</td>
</tr>
<tr>
<td>RAM requirements</td>
<td>10</td>
</tr>
<tr>
<td>rolodex cards</td>
<td>50</td>
</tr>
<tr>
<td>indexes to portals</td>
<td>50</td>
</tr>
<tr>
<td>saving changes to forums</td>
<td>18</td>
</tr>
<tr>
<td>search</td>
<td>15</td>
</tr>
<tr>
<td>for objects in forums</td>
<td>15</td>
</tr>
<tr>
<td>Online Help</td>
<td>15</td>
</tr>
<tr>
<td>Smalltalk</td>
<td>6</td>
</tr>
<tr>
<td>sound</td>
<td>6</td>
</tr>
<tr>
<td>adding effects</td>
<td>59</td>
</tr>
<tr>
<td>communicating with</td>
<td>30</td>
</tr>
<tr>
<td>deleting</td>
<td>59</td>
</tr>
<tr>
<td>push-to-talk mic option</td>
<td>37</td>
</tr>
<tr>
<td>removing a sound</td>
<td>69</td>
</tr>
<tr>
<td>setup</td>
<td>30</td>
</tr>
<tr>
<td>Sound Levels dialog</td>
<td>30</td>
</tr>
<tr>
<td>speaker on/off and volume</td>
<td>37</td>
</tr>
<tr>
<td>status of other users</td>
<td>39</td>
</tr>
<tr>
<td>troubleshooting</td>
<td>37</td>
</tr>
<tr>
<td>Squeak</td>
<td>6</td>
</tr>
<tr>
<td>starting the forums browser</td>
<td>11</td>
</tr>
<tr>
<td>templates</td>
<td>11</td>
</tr>
<tr>
<td>choosing at startup</td>
<td>12</td>
</tr>
<tr>
<td>creating new forums from</td>
<td>13</td>
</tr>
<tr>
<td>for forums</td>
<td>8</td>
</tr>
<tr>
<td>library forum</td>
<td>63</td>
</tr>
<tr>
<td>overview</td>
<td>19</td>
</tr>
<tr>
<td>save as to create new forum</td>
<td>18</td>
</tr>
<tr>
<td>TGA</td>
<td>42, 60</td>
</tr>
<tr>
<td>TIFF</td>
<td>42, 60</td>
</tr>
<tr>
<td>users</td>
<td>42, 60</td>
</tr>
<tr>
<td>adding new</td>
<td>19</td>
</tr>
<tr>
<td>allow, disallow in forums</td>
<td>19</td>
</tr>
<tr>
<td>deleting</td>
<td>19</td>
</tr>
<tr>
<td>finding forum location at login</td>
<td>12</td>
</tr>
<tr>
<td>finding from within forums</td>
<td>29</td>
</tr>
<tr>
<td>finding who's online at login</td>
<td>12</td>
</tr>
<tr>
<td>listing at login</td>
<td>12</td>
</tr>
<tr>
<td>view in forum</td>
<td>19</td>
</tr>
<tr>
<td>voice</td>
<td>30</td>
</tr>
<tr>
<td>VRML</td>
<td>42, 60</td>
</tr>
<tr>
<td>Web browser</td>
<td>42, 60</td>
</tr>
<tr>
<td>popup blockers, security warnings on Help</td>
<td>16</td>
</tr>
<tr>
<td>use</td>
<td>53</td>
</tr>
<tr>
<td>Web cards</td>
<td>50</td>
</tr>
<tr>
<td>web page</td>
<td>53</td>
</tr>
<tr>
<td>link to</td>
<td>57</td>
</tr>
<tr>
<td>white board</td>
<td>53</td>
</tr>
<tr>
<td>read or write to</td>
<td>53</td>
</tr>
<tr>
<td>Windows as a supported platform</td>
<td>10</td>
</tr>
<tr>
<td>write</td>
<td>53</td>
</tr>
<tr>
<td>to a 2D object</td>
<td>53</td>
</tr>
<tr>
<td>WRL</td>
<td>42, 60</td>
</tr>
<tr>
<td>XLS</td>
<td>42</td>
</tr>
<tr>
<td>zoom</td>
<td>28</td>
</tr>
</tbody>
</table>